geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <>
Subject [jira] Commented: (GERONIMO-2994) Apache Roller plugin
Date Sun, 15 Jun 2008 18:35:45 GMT


David Jencks commented on GERONIMO-2994:

The legal questions about the mysql plugin are tracked at

Latest comments seem to indicate we might be able to release it.

> Apache Roller plugin 
> ---------------------
>                 Key: GERONIMO-2994
>                 URL:
>             Project: Geronimo
>          Issue Type: New Feature
>      Security Level: public(Regular issues) 
>          Components: Plugins
>    Affects Versions: 1.2
>            Reporter: Peter Petersson
>            Assignee: David Jencks
>            Priority: Minor
>         Attachments: GERONIMO-2994-nolibs.patch, GERONIMO-2994-roller-patch, geronimo-plugins.xml,
geronimo-plugins.xml, geronimo-plugins_070602.xml, geronimo-web.xml, geronimo-web.xml, plan.xml,
PluginInstallerGBean.patch, pom.xml, pom.xml,,,, roller-derbydb-plan-g1_2.xml, roller-mysql-db-plan-1-2.xml,,
roller070409.patch,, roller_4_0_plugin_080103.patch, roller_4_0_plugin_080204.patch,
roller_g20_svn_070602.patch, roller_maven_ant_task_070902_0.patch, roller_maven_ant_task_070918_0.patch,
roller_plugin.patch, roller_plugin_070717.patch, roller_plugin_070803.patch, roller_plugin_070918.patch,
roller_plugin_070921.patch, roller_plugin_patch_070724.txt
> Have been working on getting Apache Roller running under Geronimo I finally got to the
point where the roller application seems to be running smoothly in Geronimo v1.2 (current
snapshot). It would be great to eventually see this application as a plugin in G so here are
pointers to resources and attached plans.
> Apache Roller v3.1 Resources (soon to be released)
> Apache roller home:
> The bundle: (until it will be
available directly via roller home)
> Required jars:
> Path to database create scripts can be found in the bundle above under: apache-roller-3.1/webapp/roller/WEB-INF/dbscripts/
> I have tested with the derby database and mysql 5. 
> There is currently a issue with G v1.2 and hibernates v3.1 (used by roller 3.1) property
loader that gets a
> FATAL [HibernateRollerImpl] Error initializing Hibernate
> java.lang.ClassCastException: java.util.HashSet
>         at org.hibernate.util.PropertiesHelper.resolvePlaceHolders(
> Hibernate is expecting a String value (This issue is fixed in hibernate 3.2 with a instanceOf
> Fortunately David Jencks hit this problem in trunk and suggested turning off the activemq
and activemq-broker modules in config.xml, to test things out, and after that everything was
running smothly :).

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message