geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Woods <dwo...@apache.org>
Subject Re: GEP: Unable to satisfy dependency from org.apache.geronimo.v21.feature.feature.group 2.1.1
Date Fri, 20 Jun 2008 17:02:21 GMT
Yep, Ganymede includes a newer JST -
    org.eclipse.jst	3.0.0.v200806111800-7U-8Y9LIrwYBUV7sHGjhtz0LTrMd
and our feature is looking for -
    [2.0.0,3.0.0)


-Donald


Jacek Laskowski wrote:
> Hi,
> 
> Just spot it today while working with P2 after I moved to Eclipse JEE
> Ganymede RC4:
> 
> !MESSAGE Unable to satisfy dependency from
> org.apache.geronimo.v21.feature.feature.group 2.1.1 to
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jst.feature.group/[2.0.0,3.0.0).
> !SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-06-20 09:18:17.562
> !MESSAGE Unable to satisfy dependency from
> org.apache.geronimo.feature.feature.group 2.1.1 to requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jst.feature.group/[2.0.0,3.0.0).
> !SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-06-20 09:18:17.562
> !MESSAGE Unable to satisfy dependency from
> org.apache.geronimo.v20.feature.feature.group 2.1.1 to
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jst.feature.group/[2.0.0,3.0.0).
> 
> The plugin seems to be working fine though - start/stop/publish worked for me.
> 
> Jacek
> 

Mime
View raw message