geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <ja...@laskowski.net.pl>
Subject Re: Websphere to Geronimo
Date Thu, 26 Jun 2008 08:07:57 GMT
On Thu, Jun 26, 2008 at 5:08 AM, NiƱo James Ramos <neonjames@gmail.com> wrote:

> May I ask:

Hi James,

(This is sort of a question for the geronimo user mailing list and we
shouldn't be answering such here, but...it's the last time, deal?)

> I am currently using Rational Software Architect v6.0.1.2
> Are there any available plugin for RSA that can support Apache Geronimo for
> easier deployment?

AFAIK, RSA 6.0 is based on Eclipse 3.0 so although it was not tested
GEP should work fine I believe. Give it a shot and report to the
geronimo *user* mailing list.

> I have an EAR file deployed using the WebSphere v6.0 runtime
> and I would want it to run using Apache Geronimo. or wouldn't it be
> possible?

I don't think so. I'm sure it would not be an automatic process and
would require some manual changes. OpenEJB which is the EJB container
for Apache Geronimo doesn't understand websphere-specific deployment
descriptors so if your application relies on them, it won't work in
Geronimo (at least as far as EJBs are concerned). It's being worked
out though. Other non-EJB-websphere-specific descriptors are not
recognized by Geronimo either. It shouldn't be a problem to do the
resource mapping again. Could you share more information on the
structure of your application? What modules are there? What's their
descriptors and such. Use the geronimo *user* mailing list.

Jacek

-- 
Jacek Laskowski
Notatnik Projektanta Java EE - http://www.JacekLaskowski.pl

Mime
View raw message