geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manu George" <manu.t.geo...@gmail.com>
Subject Re: Problem with hiding asm classes
Date Tue, 27 May 2008 19:44:24 GMT
Thanks for replying Kevan. I already opened a JIRA
https://issues.apache.org/jira/browse/GERONIMO-4082
as david jencks also mentioned that it is a bug in another thread

Regards
Manu

On Tue, May 27, 2008 at 6:22 PM, Kevan Miller <kevan.miller@gmail.com> wrote:
>
> On May 26, 2008, at 8:50 AM, Manu George wrote:
>
>> Hi,
>>     A user faced a problem with the hidden-classes element not
>> working for asm classes. The reason was the optimized class loading
>> mechanism which does not check if the classes are hidden before the
>> block below
>>
>>      //
>>       // No dice, let's offer the primordial loader a shot...
>>       //
>>       try {
>>        return resolveClass(findSystemClass(name), resolve);
>>       } catch (ClassNotFoundException cnfe) {
>>        // ignore...just being a good citizen.
>>       }
>>
>> I was able to get this to work by reverting to the safe method of
>> finding classes via the system property
>> -DXorg.apache.geronimo.kernel.config.MPCLSearchOption=safe
>>
>> Is this expected behaviour or should I open a JIRA?
>
> Doh... I'd certainly call it a bug. I think the expectation was that the
> primordial classloader would be loading the JSE classes, not
> geronimo/library classes. Note the difference in the checking between
> loadSafeClass() and loadOptimizedClass() for this case. I don't think this
> was intentional.
>
> --kevan
>

Mime
View raw message