geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shiva Kumar H R (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-256) Publish operation after an Eclipse restart deletes a deployed Web Service's "server-config.wsdd" file
Date Thu, 17 Apr 2008 06:43:21 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-256?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12589841#action_12589841
] 

Shiva Kumar H R commented on GERONIMODEVTOOLS-256:
--------------------------------------------------

https://bugs.eclipse.org/bugs/show_bug.cgi?id=119964 say this is fixed in WTP 3.0M6. However
when I tried with WTP 3.0M6 & used Web Services Wizard, I keep hitting the following error:

IWAB0489E Error when deploying Web service to Axis runtime
  axis-admin failed with  {http://xml.apache.org/axis/}HTTP
(404)/HelloWS/services/AdminService

This seems to be some other issue in WTP (see same error reported in https://bugs.eclipse.org/bugs/show_bug.cgi?id=201061
) and need to report it / follow-up in WTP bugzilla.

> Publish operation after an Eclipse restart deletes a deployed Web Service's "server-config.wsdd"
file
> -----------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-256
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-256
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 2.0.0
>         Environment: AG 2.0.2 + Geronimo Eclipse Plug-in v2.0 + WTP 2.0.1
>            Reporter: Shiva Kumar H R
>            Assignee: Shiva Kumar H R
>             Fix For: 2.1.0
>
>
> Steps to recreate:
> 1) Create a Web Service as per the instructions at 
> http://www.eclipse.org/webtools/jst/components/ws/1.5/tutorials/BottomUpWebService/BottomUpWebService.html
> 2) Test the web service using (the auto launched) Web Service Explorer. Everything works
fine.
> 3) Shut down server and restart the server. Again launch the web service. It runs fine
without any error.
> 4) Shut down server, close eclipse, restart eclipse, start server. This time try to access
the web service and you will not be able to access it.
> An initial analysis shows that in Step-4 (after a Eclipse & Server restart) the "Publish"
operation of Eclipse is deleting "server-config.wsdd" from <GERONIMO_HOME>\repository\<path-to-deployed-EAR>\<war
name>\WEB-INF directory.
> You will get the following error in the console:
> 17:01:56,218 ERROR [EngineConfigurationFactoryServlet] Unable to find config file.  Creating
new servlet engine config file: /WEB-INF/server-config.wsdd
> Is this related to the issue reported in http://mail-archive.ow2.org/jonas-team/2006-08/msg00046.html
? Needs to be explored.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message