geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shiva Kumar H R (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-272) Description of core feature confusing
Date Thu, 17 Apr 2008 03:27:21 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-272?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12589820#action_12589820
] 

Shiva Kumar H R commented on GERONIMODEVTOOLS-272:
--------------------------------------------------

Patch has been applied at revision: 648941 . Thanks again Ted.

But as you point out - it would be nice if the core feature did not show up at all in the
list to install. Any idea how to accomplish this?

> Description of core feature confusing
> -------------------------------------
>
>                 Key: GERONIMODEVTOOLS-272
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-272
>             Project: Geronimo-Devtools
>          Issue Type: Improvement
>          Components: eclipse-plugin
>    Affects Versions: 2.0.0, 2.0.2, 2.0.x, 2.1.0, 2.1.x
>            Reporter: Ted Kirby
>            Assignee: Shiva Kumar H R
>             Fix For: 2.1.0
>
>         Attachments: GD-272.patch
>
>
> When you install the eclipse plugin with the eclipse update manager, you get a choice
of Geronimo WTP Server Adapters:
>   Geronimo Core Feature, 
> and a series of versioned server adapters of the form:
>   Geronimo vX.X Server Adapter
> When you click on them, they all have the same descripton:
> "This feature provides the WTP Server Adapter and additional development tools for the
Apache Geronimo server."
> This text might be customized to include the version number, or changed to:
> "This feature provides the WTP Server Adapter and additional development tools for {color:red}this
specific version of the{color} Apache Geronimo server."
> For the core feature, however, the text is quite misleading.  Installing it does not
give you any working server adapter.  So, it's description should be changed to something
like:
> "This feature provides core support required for the WTP Server Adapter for specific
versions of the Apache Geronimo server."
> It would be nice if the core feature did not show up at all in the list to install. 
It is included by those version-specific real server adapters that need it.
> Also, not sure what these "additional development tools" are, or where the user finds
out about them, but they can probably be removed from the core feature, if that feature itself
can't be removed from the install list.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message