geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shiva Kumar H R (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-316) intermittent "Geronimo Deployment 1.2 cannot be installed." error message from the Eclipse Project Facets wizard
Date Wed, 02 Apr 2008 17:01:24 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-316?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12584669#action_12584669
] 

Shiva Kumar H R commented on GERONIMODEVTOOLS-316:
--------------------------------------------------

I had a close look at all facet extensions and the only suspect I can find is:
org.apache.geronimo.st.core: plugin.xml
<extension point="org.eclipse.wst.common.project.facet.core.runtimes">
...
        <adapter>
            <runtime-component id="org.apache.geronimo.runtime"/>
            <factory
                class="org.eclipse.jst.server.core.internal.RuntimeClasspathProvider$Factory"/>
            <type
                class="org.eclipse.jst.common.project.facet.core.IClasspathProvider"/>
        </adapter>

The referenced class "org.eclipse.jst.common.project.facet.core.IClasspathProvider" doesn't
exist. 

Any idea what that <adapter> is used for? and can we remove it?

> intermittent "Geronimo Deployment 1.2 cannot be installed." error message from the Eclipse
Project Facets wizard
> ----------------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-316
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-316
>             Project: Geronimo-Devtools
>          Issue Type: Sub-task
>            Reporter: Tim McConnell
>            Assignee: Tim McConnell
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message