geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Warner" <jaw...@gmail.com>
Subject Re: DayTrader build error
Date Wed, 12 Mar 2008 11:49:34 GMT
selesh,

You could try using maven to install the jar into the repo.  This would
guarantee that the jar would be in the correct directory structure.
Instructions on what command to use and how to use it can be found here:
http://maven.apache.org/plugins/maven-install-plugin/install-file-mojo.html

Hope this helps,

On Wed, Mar 12, 2008 at 7:31 AM, seleshmaster <seleshmaster@gmail.com>
wrote:

>
>
>
> Kevan Miller wrote:
> >
> >
> > On Mar 11, 2008, at 6:52 AM, seleshmaster wrote:
> > <snip>
> >
> >> thx again
> >>
> >> I dont know what I am missing but I installed the jar file under
> >> maven/lib
> >> directory where other jar file exist but I am still getting the same
> >> error.
> >> by the way, i reverted back to maven 2.0.6
> >
> >
> > The maven-ejb-plugin needs to end up in your .m2 repository. For me,
> > it's:
> >
> > /Users/kevan/.m2/repository/org/apache/maven/plugins/maven-ejb-plugin/
> > 2.1/maven-ejb-plugin-2.1.jar
> >
> > --kevan
> >
> >
> >
> >
> >
>
> thx kevan;
>
> obviously I am still missing something else cause I am still getting the
> same error.
>
> here is what i did
>
> 0) I installed maven.2.0.7
>
> Maven version: 2.0.7
> Java version: 1.5.0_13
> OS name: "mac os x" version: "10.5.2" arch: "i386"
>
>
> 1) I checked out the source. svn co ....
> 2) I put maven-ejb-plugin.jar under
>
> /Users/seleshmaster/.m2/repository/org/apache/maven/plugins/maven-ejb-plugin
> Note: for some reason, there was no directory name "2.1", so  I just
> created
> it manually and put the .jar file there too
> 3) and from /Users/seleshmaster/workspace/trunk directory i run "mvn
> install"
>
> 4) and I am getting this error
>
> ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] The plugin 'org.apache.maven.plugins:maven-ejb-plugin' does not
> exist
> or no valid version could be found
>
>
> thx for the help.
>
> --
> View this message in context:
> http://www.nabble.com/DayTrader-build-error-tp15973242s134p16001762.html
> Sent from the Apache Geronimo - Dev mailing list archive at Nabble.com.
>
>


-- 
~Jason Warner

Mime
View raw message