geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Gawor" <jga...@gmail.com>
Subject Re: Upgrading Axis2 version / Geronimo's JAXWS 2.1 plan
Date Mon, 17 Mar 2008 15:23:32 GMT
Dims,

It is my understanding that if we do upgrade to JAX-WS 2.1 we will be
breaking Java EE 5 TCK (becuase there are some additional API in
JAX-WS 2.1 / JAX-B 2.1). Also, since JAX-WS 2.1 requires JAX-B 2.1 and
in Geronimo we use JAX-B in a bunch of components, upgrading them
might take a little bit of time and effort to make sure everything
still works as supposed to.

Jarek

On Thu, Mar 13, 2008 at 10:24 PM, Davanum Srinivas <davanum@gmail.com> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
>  Hash: SHA1
>
>  Folks,
>
>  At Axis2, we are trying to push out a 1.4 Release soon. Planning an RC1 this weekend/monday.
>
>  So questions, What's the plan to upgrade to JAXWS 2.1? I believe the cxf folks are already
at JAXWS 2.1.
>
>  Could we please upgrade both (if not already) to get some TCK coverage and make sure
we fix anything that crops up by
>  the time we cut Axis2 1.4?
>
>  thanks,
>  dims
>  -----BEGIN PGP SIGNATURE-----
>  Version: GnuPG v1.4.5 (Cygwin)
>
>  iD8DBQFH2eHUgNg6eWEDv1kRAkcCAKCJHdRVrvq7eQXDYQdzVk5RaoHoqgCfYzUj
>  wH0CdAi/fLegy77jrcprAnM=
>  =b9Xg
>  -----END PGP SIGNATURE-----
>
>  ---------------------------------------------------------------------
>  To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
>  For additional commands, e-mail: axis-dev-help@ws.apache.org
>
>

Mime
View raw message