geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Woods <dwo...@apache.org>
Subject Re: Gshell fails to launch on trunk
Date Wed, 12 Mar 2008 02:38:39 GMT
Hmmm. Sounds like our build needs to either create this conf file based 
on our dependency levels or change how GShell is setup....


-Donald

Jason Warner wrote:
> Sorry for the confusion, David.  Responses inline.
> 
> On Tue, Mar 11, 2008 at 6:54 PM, David Jencks <david_jencks@yahoo.com 
> <mailto:david_jencks@yahoo.com>> wrote:
> 
> 
>     On Mar 11, 2008, at 12:37 PM, Jason Warner wrote:
> 
>      > I checked out the latest trunk and tried to launch gshell, but
>      > found that it failed due to an error in plexus.  The problem seems
>      > to be caused by the recent update to using mina 1.1.5.
> 
>     update of what?
> 
> 
> Geronimo trunk has moved from a dependency on mina 1.1.2 to a dependency 
> on mina 1.1.5.
> 
> 
>      > The 1.0-alpha-1 version of gshell that is being used is telling
>      > plexus to look for version 1.1.2 of mina-core.  When it doesn't
>      > find it, it blows up and the console isn't launched.  This can be
>      > fixed by changing the version of mina that it is searching for in
>      > the gsh-classworlds.conf file in the etc directory.
> 
>     Doesn't that mean the the geronimo configuration for gshell is
>     specifying mina-core 1.1.2?  How is gshell specifying something else
>     as you say above?
> 
> 
> I'm not quite sure what you're asking with this but I'll try to answer 
> anyways.  The version of gshell that is used in trunk currently is 
> 1.0-alpha-1.  The gsh-classworlds.conf file for this version of gshell 
> is looking for mina 1.1.2.  Geronimo no longer has a dependency on mina 
> 1.1.2.  It is now dependent on mina 1.1.5.  Because of this, Plexus 
> (which attempts to load the classes specified in gsh-classworlds.conf) 
> crashes on load. 
> 
> 
>      > What would be the proper fix for this?  1.0-alpha-1 is the latest
>      > tag.  It looks like trunk was recently updated to use mina-1.1.6.
> 
>     trunk of what?
> 
> 
> GShell trunk has recently been updated to mina-1.1.6
> 
> 
>      >   I imagine we'd have the same problem using a snapshot build of
>      > trunk given that there's a version difference.  Is there another
>      > way to fix this problem or do we need to move gshell trunk over to
>      > 1.1.5 and then include the snapshot build in geronimo trunk?
> 
>     I don't understand where the problem actually is.  I would start by
>     making sure that the version of mina-core that is installed for
>     gshell to use is the one specified in etc/sdh-classworlds.conf and
>     preferably the same one as in the geronimo repository, if there is
>     one.  As long as these are the same I'd expect plexus to be happy.
>     Then we can try to figure out what the latest version of mina gshell
>     1.0-alpha-1 can work with.
> 
>     Maybe I'm missing the problem entirely...
>     thanks
>     david jencks
> 
> Halfway through my responses, I just realized that I'm probably blowing 
> the problem way out of proportion.  I misunderstood how gshell was 
> assembled in the server, but I think I understand it now.  At least, I 
> understand it well enough to point out that this can actually be fixed 
> easily by updating the gsh-classworlds.conf file in 
> assemblies/geronimo-boilerplate-minimal/src/main/underlay/etc/ to use 
> mina-1.1.5.  I can see now why you were so confused, David.  Sorry about 
> that.
> 
> 
> 
>      >
>      > Thanks,
>      >
>      >
>      > --
>      > ~Jason Warner
> 
> 
> 
> 
> -- 
> ~Jason Warner

Mime
View raw message