geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vamsavardhana Reddy" <c1vams...@gmail.com>
Subject Re: Geronimo Tomcat 2.1 clustering - application deployment problems
Date Thu, 20 Mar 2008 11:39:48 GMT
Gianny,

It was a mutlicast problem.  After I turned the firewall off (service
iptables stop), the sample app ran as expected.

++Vamsi

On Thu, Mar 20, 2008 at 2:24 PM, Gianny Damour <
gianny.damour@optusnet.com.au> wrote:

> Hello Vamsi,
>
> If the applications display distinct numbers, then the nodes do not
> see each other. I think this is a problem with multicasting.
>
> Could you please confirm that you have uncommented the last line of
> etc/rc.d/start-server,default.groovy which sets the system property
> java.net.preferIPv4Stack? Without this property set to true,
> multicasting fails at least on Mac OS X and maybe FC.
>
> If this property is already set, then I suggest you to check that
> multicasting is working ok on your box.
>
> Thanks,
> Gianny
>
> On 20/03/2008, at 4:08 AM, Vamsavardhana Reddy wrote:
>
> > Hi Gianny,
> >
> > I observe that the sample application does not run as expected when
> > I try the clustering scenario on FedoraCore.  Application running
> > on each node displays its own set of numbers starting from 1 with
> > the background color of the squares being the node.name set at
> > startup.  I observed the same behavior with G Jetty 2.1 and G
> > Tomcat 2.1 distros.  What is to be done differently on Linux?
> >
> > ++Vamsi
> \
>

Mime
View raw message