geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pete Robinson (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMO-3890) STRUTS2 EXTERMELY SLOW (UNUSABLE) IN GERONIMO - OK IN OTHER SERVERS
Date Sun, 02 Mar 2008 20:40:50 GMT
STRUTS2 EXTERMELY SLOW (UNUSABLE) IN GERONIMO - OK IN OTHER SERVERS 
--------------------------------------------------------------------

                 Key: GERONIMO-3890
                 URL: https://issues.apache.org/jira/browse/GERONIMO-3890
             Project: Geronimo
          Issue Type: Bug
      Security Level: public (Regular issues)
    Affects Versions: 2.0.2, 2.0.1
         Environment: 2.5Ghz Pentium 4. + 1.5Gb RAM. + Eclipse 3.3 + Geronimo 2.0.2 + Struts
2.0.11+ + Windows 2000 + JRE 1.5.0_09 + Apache Tomcat 6
            Reporter: Pete Robinson


Hello All,

Scenario
I have a problem when trying to develop a new "Dynamic Web Project" in Geronimo that uses
struts2.

Problem
I'm experiencing major performance problems using struts2. Other servers (Jonas 4.8.6, JBoss
4.2.2.GA), do not demonstrate this error at all.

After days (3 weeks) of trying to get a simple project to work, I've reduced the problem description
to the bare minimum.

Create the example struts2 project from the struts2.org website as described here:

    http://www.struts2.org/free-struts2-book/developing-your-first-struts2-application/

And, deploy from eclipse. You should have no problems. Now, call it up.

    http://localhost:8080/struts2demo/

And look how terribly SLOW this works. I wait for 30 seconds for the server to respond then
30-60 seconds for it to paint the web page.

Now, add a few testfields. See how each "line" (label/field pair) takes 10 seconds to render.


This must be a bug or config problem

Any ideas?
I've even tried running on a linux installation. Same problem.
I've tried IE and Firefox, so it's not a browser issue.
I've also tried Geronimo 2.0.1 and Geronimo 2.0.2. Same problem.
This problem does not occur running under jBoss-4.2.2.GA.

Thanks in Advance!
Pete Robinson

Environment
2.5Ghz Pentium 4. 1.5Gb RAM. Eclipse 3.3 + Geronimo 2.0.2 + Struts 2.0.11+ + Windows 2000
+ JRE 1.5.0_09 Tomcat 6.X


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message