you need a 1.5 JDK to compile the source in trunk because of the annotations for EE5... if you want to use JDK 1.4.X and J2EE 1.4, i would suggest looking at the 1.2 branch.

hope this helps...

On Tue, Feb 5, 2008 at 12:57 PM, B.J. Reed <bjreed2@gmail.com> wrote:
Hi, I've run into a problem with building the trunk version of daytrader.

When I do mvn site, I am getting about 15 - 20 errors all similar to the
ones below, but I can't seem to figure out exactly what in the pom.xml
is setting the source to 1.4 and how to fix it.

First 3 errors:
Embedded error: Error rendering Maven report: Exit code: 1 -
C:\g\daytrader\trunk\modules\ejb\src\main\java\org\apache\geronimo\samples\daytrader\AccountDataBea
n.java:30: annotations are not supported in -source 1.4 (try -source 1.5
to enable annotations)
@Entity(name = "accountejb")
 ^
C:\g\daytrader\trunk\modules\ejb\src\main\java\org\apache\geronimo\samples\daytrader\AccountDataBean.java:79:
generics are not supported in -source 1.4 (try -source 1.5 to enable
generics)
   private Collection<OrderDataBean> orders;
                     ^
C:\g\daytrader\trunk\modules\ejb\src\main\java\org\apache\geronimo\samples\daytrader\AccountProfileDataBean.java:23:
annotations are not supported in -source 1.4 (try -source 1.5 to enable
annotations)
@Entity(name = "accountprofileejb")
 ^

Thanks in advance for any help,

B.J.



--
"I say never be complete, I say stop being perfect, I say let... lets evolve, let the chips fall where they may." - Tyler Durden