geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Woods <dwo...@apache.org>
Subject Re: long-term buildability of released versions?
Date Tue, 05 Feb 2008 19:20:10 GMT
There are newer released versions of surefire-api we can use - 2.3, 
2.3.1 and 2.4.  I'll defer to someone who knows our maven-plugins better 
to determine if we can move up to a newer version....

The only release of jtidy is 4aug2000r7-dev.  The latest snapshot is 
http://jtidy.sourceforge.net/snapshots/jtidy/jtidy/8.0-SNAPSHOT/jtidy-8.0-20060801.131059-3.jar.

  I asked to join the project, but we may need to copy that jar into our 
local repo dir as a short-term solution.


-Donald


Jarek Gawor wrote:
> I've fixed 1) and 2) in trunk, branches/2.0, and branches/2.1.
> 
> For 1) add the exclusion like David mentioned. For 2) just remove the
> <version> element for that api in geronimo-jaxws/pom.xml. It's really
> not needed there.
> 
> I'm not sure about the other two.
> 
> Jarek
> 
> On Feb 5, 2008 12:25 PM, toby cabot <toby@caboteria.org> wrote:
>> Thanks David, it sounds as if we do want a SNAPSHOT-less build.
>>
>> These snapshots croak 2.0.2's offline build:
>>
>> | 1) org.apache.ws.scout:jaxr-api:jar:SNAPSHOT
>> |
>> |   Path to dependency:
>> |         1) org.apache.geronimo.modules:geronimo-webservices:jar:2.0.2
>> |         2) org.apache.ws.scout:scout:jar:1.0rc1
>> |         3) org.apache.ws.scout:jaxr-api:jar:SNAPSHOT
>> |
>> | 1) org.apache.axis2:axis2-jaxws-api:jar:SNAPSHOT
>> |
>> |   Path to dependency:
>> |         1) org.apache.geronimo.modules:geronimo-jaxws:jar:2.0.2
>> |         2) org.apache.axis2:axis2-jaxws-api:jar:SNAPSHOT
>> |
>> | 1) org.apache.maven.surefire:surefire-api:jar:2.1-SNAPSHOT
>> |
>> |   Path to dependency:
>> |         1) org.apache.geronimo.plugins:geronimo-maven-plugin:maven-plugin:2.0.2
>> |         2) org.apache.maven.surefire:surefire-api:jar:2.1-SNAPSHOT
>> |
>> | 1) jtidy:jtidy:jar:8.0-SNAPSHOT
>> |
>> |   Path to dependency:
>> |         1) org.apache.geronimo.plugins:testsuite-maven-plugin:maven-plugin:2.0.2
>> |         2) jtidy:jtidy:jar:8.0-SNAPSHOT
>>
>> Not bad.  If you'd like I can try to find the nearest released
>> versions that correspond to the snapshots and see what happens if I
>> substitute them.
>>
> 

Mime
View raw message