geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <joe.b...@earthlink.net>
Subject Re: Build of trunk failed due to org.apache.maven.plugin.enforcer.RequireJavaVersion
Date Mon, 04 Feb 2008 19:06:53 GMT
Hi Dan and welcome aboard!

At the moment you need to build with a 1.5 jre.  I'm using 1.5.0_14 but 
any 1.5 should work.  There's a check included in the root pom to 
require 1.5 or higher but not 1.6.

HTH,
Joe



Dan Becker wrote:
> Hello folks,
> 
> This is my first post here, but I thought this might be a quickie for the
> Geronimo community.
> 
> I am attempting to build the trunk of Geronimo using the command "mvn
> install" from my local trunk checkout. A number fo poms are downloaded, and
> then my build runs into a problem (most likely
> a newbie maven setup problem, did not see similar problem on list):
> [INFO] [enforcer:enforce {execution: default}]
> [WARNING] Rule 0: org.apache.maven.plugin.enforcer.RequireJavaVersion failed
> wit
> h message: Detected JDK Version: 1.6.0-4 is not in the allowed range
> [1.5,1.6).
> 
> Environment:
> java version "1.6.0_04"
>    Java(TM) SE Runtime Environment (build 1.6.0_04-b12)
>    Java HotSpot(TM) Client VM (build 10.0-b19, mixed mode, sharing)
> Maven 2.0.7
> svn 1.4.6
> Windows XP (Build 2600.xpsp.0501011-1528: Service Pack 2)
> 
> Any pointers for how to resolve the Java version issue or some other setup
> item I may have forgotten?
> Thanks, Dan Becker
> 


Mime
View raw message