geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manu George" <manu.t.geo...@gmail.com>
Subject Re: Regarding SSO across admin console
Date Wed, 27 Feb 2008 21:07:21 GMT
Hi Joseph,
            Thanks for the response. I figured it out. I was not doing
something correctly as mentioned in the other mail I sent. I was
developing an EJB Server portlet for the console and was facing an
error there. Will be attaching a patch shortly.

Regards
Manu

On Thu, Feb 28, 2008 at 2:29 AM, Joseph Leong <josephcleong@gmail.com> wrote:
> Hi Manu,
>
> As Kevan mentioned - I ran into a similar issue as well while working on the
> plugin installer in console.   But I can't say it better than Joe Bohn
> (above), the issue rooted from the JSessionID getting corrupted.  So the
> first suggestion would be to verify whether the JSessionID is getting
> corrupted or deleted. Let us know what ya find and hopefully we can step
> through this.
>
> Which portlet is this for?
>
> -Joseph Leong
>
>
> On Wed, Feb 27, 2008 at 12:19 PM, Joe Bohn <joe.bohn@earthlink.net> wrote:
> >
> >
> >
> > Manu George wrote:
> > > Hi,
> > >        I added a new portlet to the admin console via the newHi
> >
> >
> >
> > > pluggable mechanism. However when I click on the link to that portlet
> > > I am always asked to authenticate even though I have authenticated on
> > > the login page of the admin console. How can I configure my portlet to
> > > also be part of the single sign on across the admin console.
> > >
> > > Regards
> > > Manu
> > >
> >
> >
> >
> >
> > Hi Manu,
> >
> > I don't know the answer but here are some things you can investigate:
> >
> > 1)  I know that we had issues with this and the pluggable console
> > earlier with Jetty.  I thought those issues were resolved but if you are
> > using Jetty you might want to give Tomcat a try.
> >
> > 2)  The problem you describe typically happens with the portlet session
> > gets corrupted/reset or when the JSessionID cookie gets
> > corrupted/deleted.  You might want to check if you are doing anything
> > special that might affect the session.
> >
> > Finally, the doc that Kevan referenced includes a sample.  You might
> > want to try that sample first and then begin adding in your specifics
> > until the problem surfaces.
> >
> > Joe Bohn
> >
> >
>
>

Mime
View raw message