geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Becker <dan.o.bec...@gmail.com>
Subject Re: Build of trunk failed due to org.apache.maven.plugin.enforcer.RequireJavaVersion
Date Mon, 04 Feb 2008 21:29:27 GMT


Dan Becker wrote:
> 
> This is my first post here, but I thought this might be a quickie for the
> Geronimo community.
> 
> I am attempting to build the trunk of Geronimo using the command "mvn
> install" from my local trunk checkout. A number fo poms are downloaded,
> and then my build runs into a problem (most likely
> a newbie maven setup problem, did not see similar problem on list):
> [INFO] [enforcer:enforce {execution: default}]
> [WARNING] Rule 0: org.apache.maven.plugin.enforcer.RequireJavaVersion
> failed wit
> h message: Detected JDK Version: 1.6.0-4 is not in the allowed range
> [1.5,1.6).
> 

Thanks for your help folks. You are indeed correct that the build must be
done with JDK 1.5 or greater, but not 1.6. I was thrown off by the error
message with the range [1.5,1.6). I guess the round paren excludes the 1.6
endpoint. Anyway, I am now progressing.

Thanks, Dan Becker
-- 
View this message in context: http://www.nabble.com/Build-of-trunk-failed-due-to-org.apache.maven.plugin.enforcer.RequireJavaVersion-tp15273467s134p15277978.html
Sent from the Apache Geronimo - Dev mailing list archive at Nabble.com.


Mime
View raw message