geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan D. Cabrera" <>
Subject Re: [YOKO]
Date Tue, 15 Jan 2008 17:50:00 GMT

On Jan 15, 2008, at 7:03 AM, Rick McGuire wrote:

> The Yoko ORB code still generates 1.4 compatible code.  Since the  
> ORB doesn't have any direct dependencies on Geronimo, it probably  
> can be maintained as just being dependent on 1.4.  On the other  
> hand, there are many times I wished I could use some of the stuff in  
> 1.5 (such as the concurrency classes).  Harmony is a 1.5 JDK, so 1.4  
> compatibility is not an issue for them.  Yoko is used in the never  
> released 1.2 Geronimo version too.  I suspect that's going to remain  
> in its never released state so I don't think Geronimo is an issue  
> either.
> I can go either way on the JDK issue depending on what the consensus  
> is.

I would LOVE to use JDK1.5.  Maybe Yoko 2.0?  There are plenty of  
backport paths so it's not like we would  be abandoning JDK1.4.


View raw message