geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Minimal server startup issue
Date Tue, 11 Dec 2007 08:23:06 GMT

On Dec 10, 2007, at 9:12 PM, Gianny Damour wrote:

> Hi,
>
> Thanks for having fixed this problem David. I may have introduced  
> this bug while working on the property editor stuff. So, I will  
> have a look at it and see if we can avoid this explicit  
> registration of property editors.

I recall this problem from long long ago.  I think it has reappeared  
when I started constructing the config.xml files and they are no  
longer in order of expected module startup.  I thought of a couple  
other possible solutions such as ordering the configs in config.xml  
according to the dependencies, but we'd still be relying on more or  
less accidental behavior, namely a particular gbean having its  
gbeanInfo loaded before any attributes needing the property editor  
are loaded.  I think explicitly calling out the property editor to be  
used is a much more satisfactory solution.  Even though you didn't  
cause  the problem you might be able to think of a better way to fix  
it :-)

thanks
david jencks

>
> Thanks,
> Gianny
>
> On 11/12/2007, at 1:14 PM, David Jencks wrote:
>
>> Jarek found a startup ordering issue in the minimal servers that I  
>> solved by explicitly specifying the property editor for the  
>> defaultEnvironment attributes.  Rev. 603109.
>>
>> thanks
>> david jencks
>>
>


Mime
View raw message