geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: svn commit: r604053 - /geronimo/server/trunk/pom.xml
Date Fri, 14 Dec 2007 05:13:52 GMT
I've changed the rule to allow 2.0.5, 2.0.6 and 2.0.7, which AFAIK  
should build the tree correctly.

I've also created an issue to fix the 2.0.8 problems:

     https://issues.apache.org/jira/browse/GERONIMO-3705

--jason


On Dec 13, 2007, at 5:49 PM, Jarek Gawor wrote:

> Ok, sure but doesn't that cut off 2.0.5 and 2.0.6 users?
>
> Jarek
>
> On Dec 13, 2007 8:28 PM, Jason Dillon <jason@planet57.com> wrote:
>> Aye.
>>
>> --jason
>>
>>
>>
>> On Dec 13, 2007, at 5:13 PM, Jay D. McHugh wrote:
>>
>>> I believe that the build will crash if you use Maven 2.0.8
>>>
>>> That is probably why Jason forced the maven version.
>>>
>>> Jay
>>>
>>> Jarek Gawor wrote:
>>>> Jason,
>>>>
>>>> Can you give a reason for this change? I might have to update a few
>>>> machines.
>>>>
>>>> Thanks,
>>>> Jarek
>>>>
>>>> On Dec 13, 2007 5:41 PM,  <jdillon@apache.org> wrote:
>>>>> Author: jdillon
>>>>> Date: Thu Dec 13 14:41:50 2007
>>>>> New Revision: 604053
>>>>>
>>>>> URL: http://svn.apache.org/viewvc?rev=604053&view=rev
>>>>> Log:
>>>>> Require Maven 2.0.7 for now
>>>>>
>>>>> Modified:
>>>>>   geronimo/server/trunk/pom.xml
>>>>>
>>>>> Modified: geronimo/server/trunk/pom.xml
>>>>> URL: http://svn.apache.org/viewvc/geronimo/server/trunk/pom.xml?rev=604053&r1=604052&r2=604053&view=diff
>>>>> =
>>>>> =
>>>>> =
>>>>> =
>>>>> =
>>>>> =
>>>>> =
>>>>> =
>>>>> =
>>>>> =
>>>>> = 
>>>>> = 
>>>>> ==================================================================
>>>>> --- geronimo/server/trunk/pom.xml (original)
>>>>> +++ geronimo/server/trunk/pom.xml Thu Dec 13 14:41:50 2007
>>>>> @@ -2095,9 +2095,9 @@
>>>>>                                    <version>[1.5,1.6)</version>
>>>>>                                </requireJavaVersion>
>>>>>
>>>>> -                                <!-- Allow any Maven >= 2.0.5
-->
>>>>> +                                <!-- Require Maven 2.0.7 -->
>>>>>                                <requireMavenVersion>
>>>>> -                                    <version>[2.0.5,)</version>
>>>>> +                                    <version>[2.0.7]</version>
>>>>>                                </requireMavenVersion>
>>>>>                            </rules>
>>>>>                        </configuration>
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>


Mime
View raw message