geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Warner" <jaw...@gmail.com>
Subject Re: Trying to implement GShell ssh command (jira issue GSHELL-16)
Date Wed, 07 Nov 2007 03:07:15 GMT
Hi Ken,

I'm a little confused by the order of events that transpired here.
When do you get this error?  When you try to run the command?

On Nov 6, 2007 9:51 PM, Ken Treimann <kctreima@ncsu.edu> wrote:
> Hello,
>
> I am attempting to implement this functionality for contribution, but am
> running into this issue:
>
> ERROR ComponentLookupException: Unable to lookup component
> 'org.apache.geronimo.gshell.command.Command', it could not be created
>
> Basically I copied RshCommand, and created a secure channel by adding a
> port forwarder using the PortForwardingL example from JSch. In my
> initial investigation, I copied RshCommand, made no changes other than
> the class name and command ID, ran it, and it successfully opened an rsh
> to a rsh-server. After adding the port forwarder, a UserInfo helper
> class used by the JSch session, and command-line options for the ssh
> user and password, I get the error. I tried to undo everything I did to
> return to what previously worked, but I still get the error. There is
> some fundamental GShell-ness that I'm missing here, so can anyone give
> me a clue where I should start?
>
>
> Thanks,
> -Ken
>

Mime
View raw message