geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Treimann <kctre...@ncsu.edu>
Subject Trying to implement GShell ssh command (jira issue GSHELL-16)
Date Wed, 07 Nov 2007 02:51:49 GMT
Hello,

I am attempting to implement this functionality for contribution, but am 
running into this issue:

ERROR ComponentLookupException: Unable to lookup component
'org.apache.geronimo.gshell.command.Command', it could not be created

Basically I copied RshCommand, and created a secure channel by adding a 
port forwarder using the PortForwardingL example from JSch. In my 
initial investigation, I copied RshCommand, made no changes other than 
the class name and command ID, ran it, and it successfully opened an rsh 
to a rsh-server. After adding the port forwarder, a UserInfo helper 
class used by the JSch session, and command-line options for the ssh 
user and password, I get the error. I tried to undo everything I did to 
return to what previously worked, but I still get the error. There is 
some fundamental GShell-ness that I'm missing here, so can anyone give 
me a clue where I should start?


Thanks,
-Ken

Mime
View raw message