geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ken Treiman (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GSHELL-16) New command: ssh
Date Wed, 07 Nov 2007 01:31:50 GMT

    [ https://issues.apache.org/jira/browse/GSHELL-16?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12540647
] 

Ken Treiman commented on GSHELL-16:
-----------------------------------

I am attempting to implement this functionality for contribution, but am running into this
issue:

ERROR ComponentLookupException: Unable to lookup component
'org.apache.geronimo.gshell.command.Command', it could not be created

Basically I copied RshCommand, and created a secure channel by adding a port forwarder using
the PortForwardingL example from JSch.  In my initial investigation, I copied RshCommand,
made no changes other than the class name and command ID, ran it, and it successfully opened
an rsh to a rsh-server.  After adding the port forwarder, a UserInfo helper class used by
the JSch session, and command-line options for the ssh user and password, I get the error.
 I tried to undo everything I did to return to what previously worked, but I still get the
error.  There is some fundamental GShell-ness that I'm missing here, so can anyone give me
a clue where I should start?

> New command: ssh
> ----------------
>
>                 Key: GSHELL-16
>                 URL: https://issues.apache.org/jira/browse/GSHELL-16
>             Project: GShell
>          Issue Type: New Feature
>      Security Level: public(Regular issues) 
>          Components: Commands
>            Reporter: Jason Dillon
>            Assignee: Jason Dillon
>            Priority: Minor
>             Fix For: 1.0-alpha-1
>
>
> Can wrap the Jsch API to make a ssh command

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message