geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Does bin/start-server work anymore?
Date Fri, 16 Nov 2007 12:13:59 GMT

On Nov 14, 2007, at 12:54 AM, Jason Dillon wrote:

> I just tried to boot up the server today (trunk) and it just appears  
> to hang after:
>
> Booting Geronimo Kernel (in Java 1.5.0_13)...
>
> And then eventually times out.
>
> Anyone know what is going on?  I have a few changes to the GShell  
> integration, but I don't really like to commit them when w/o my  
> changes it doesn't work.
>
> :-(

Hmmm. Can you grab a stack trace while it's timing out? kill -3 <java- 
pid>

My trunk build is a bit dated, but starts fine for me...

I've had problems on my Mac with G 2.0.2 and the Leopard 1.5 JSE.  
There's a deadlock during startup between main thread and the  
finalizer thread involving the OpenJPA javaagent. We worked around  
this problem once before. I'm not sure what changed between 2.0.1 and  
2.0.2 to cause the problem. I tried a simple work-around, but didn't  
work... I haven't had much time to dig any further...

--kevan 
  

Mime
View raw message