geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Gawor (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (GERONIMO-3545) Upgrade Apache Derby to 10.3.1.4
Date Mon, 19 Nov 2007 06:23:43 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-3545?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jarek Gawor reopened GERONIMO-3545:
-----------------------------------


Unfortunately, it looks like Derby 10.3.1.4 has some bug that causes some TCK tests to fail.
The bug looks like https://issues.apache.org/jira/browse/DERBY-3094. I can replicate the error
by executing the following using ij tool:

connect 'jdbc:derby:menuDB;create=true';
CREATE TABLE customer (code CHAR(10), price INTEGER);
insert into customer (code, price) values ('foo', 1), ('foo', 2), ('bar', 3), ('foobar', 4);
select code,count(code) FROM customer GROUP BY code HAVING code IN ('foo', 'bar');

This works fine with 10.2.2.0. So it looks like we will need to downgrade to the older version
of Derby.


> Upgrade Apache Derby to 10.3.1.4
> --------------------------------
>
>                 Key: GERONIMO-3545
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-3545
>             Project: Geronimo
>          Issue Type: Task
>      Security Level: public(Regular issues) 
>          Components: databases
>    Affects Versions: 2.1
>            Reporter: Jacek Laskowski
>            Assignee: Jacek Laskowski
>             Fix For: 2.1
>
>
> Upgrade Derby to 10.3.1.4

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message