geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shiva Kumar H R" <shiv...@gmail.com>
Subject Re: request for devtools doc for developing in eclipse
Date Wed, 03 Oct 2007 12:58:46 GMT
Interesting discussions going on! Thanks Jarek for bringing this up. I would
be happy to have a plugin that's specific to a particular version of
Geronimo, as it would ease development a lot ;) , but after seeing Ted &
Lin's points, I quickly realize that I am not seeing the complete picture.

I think we should start a separate [Discuss] thread on dev-list about this,
with its pros & cons and solicit more feedback/suggestions.

Thanks,
Shiva

On 10/2/07, Ted Kirby <ted.kirby@gmail.com> wrote:
>
> I think it's cool that one plugin supports all versions of Geronimo.
> I think this can be quite helpful in migrating from one version of
> Geronimo to the next.  I also understand Jarek's concern.  We may well
> want to remove 1.2 from our build.  Can we add a build target that
> only builds 2.0?  Maybe that's the default, and another target says
> build all, or you can choose which server versions you want to include
> in your build.
>
> The 2.0 plugin provides a full WTP server adapter, one for each
> Geronimo version.  The 1.0 plugin used a generic WTP server adapter.
> I don't know if both may coexist in one eclipse installation.
>
> Ted Kirby
>
> On 10/2/07, Tim McConnell <tim.mcconne@gmail.com> wrote:
> > Hi Jarek, I will also update the build page later today. And I agree
> with you
> > that the plugin should support only a specific version of the Geronimo
> server.
> > It's one of the functions I hope we can add to an upcoming releases.
> Thanks for
> > the suggestion.....
> >
> > Jarek Gawor wrote:
> > > Also, yesterday I could not find documentation where to checkout/look
> > > at the source code of the plugin. The build page appeared to be empty.
> > >
> > > On a related note, once I checked out the code from svn and started
> > > building the plugin, it started downloading Geronimo 1.1 and 1.2 bits.
> > > So I was wondering what is the reason for the plugin to support all
> > > previous versions of Geronimo?. Why not have a plugin that's specific
> > > to a particular version of Geronimo? For example, plugin 2.0.x
> > > supports and works only with G 2.0.x.
> > >
> > > Jarek
> > >
> > > On 10/2/07, Ted Kirby <ted.kirby@gmail.com> wrote:
> > >> Can someone put updated doc for developing the geronimo eclipse and
> > >> J2G plugins in the wiki, and link to them from the devtools home
> page?
> > >>
> > >> http://cwiki.apache.org/GMOxDOC11/geronimo-eclipse-plugin-faq.htmlhas
> > >> doc for the 1.x plugin.  There is a link to a blank page for the
> > >> eclipse plugin from the devtools page, but no similar link for j2g.
> > >>
> > >> This would be helpful.  I tried to find that blank page for the
> > >> eclipse plugin in the wiki to update it, but was unsuccessful.  What
> > >> is the URL for the wiki page to
> > >>
> http://geronimo.apache.org/developing-the-geronimo-eclipse-plugin-in-eclipse.html
> > >> ?  Or, is this not a page that is generally accessible?
> > >>
> > >> Thanks,
> > >> Ted Kirby
> > >>
> > >
> >
> > --
> > Thanks,
> > Tim McConnell
> >
>

Mime
View raw message