geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <joe.b...@earthlink.net>
Subject Re: Build issue with trunk - build hangs
Date Tue, 16 Oct 2007 17:47:50 GMT

Thanks for all the responses!

The cpu is at 0.

It seems that the problem is related to building in the background using 
nohup and tailing the output.  If I build in the foreground without 
nohup then I don't see the hang.

The hang is always during the installation of the car-maven-plugin.  So 
there must be something involved in that installation that requires an 
attached terminal.

Thanks,
Joe


Matt Hogstrom wrote:
> Joe,
> 
> On nique you can use the IBM JDK to get a heap dump.  Although, the 
> question I have is does your system hang in terms of 0% CPU or some 
> %CPU?  If your CPU is at 0 its probably another problem not related to 
> heap.  The thread dump is a good idea.
> 
> 
> On Oct 16, 2007, at 10:37 AM, Joe Bohn wrote:
> 
>> Thanks Erik.  Even with increasing it to your settings my OpenSUSE 
>> still hangs at the point of installing the car-maven-plugin.
>>
>> Things must have really changed with this plugin to require 
>> substantially more memory or perhaps there are other issues.  I think 
>> I may just install a new OS on these machines anyway (perhaps SLES).
>>
>> I'm still interested if anybody has had success with OpenSUSE if you 
>> happen to see this.
>>
>> Thanks,
>> Joe
>>
>>
>> Erik B. Craig wrote:
>>> Joe,
>>> I was running into the same issue on CentOS, my MAVEN_OPTS were 
>>> -Xmx512m -XX:MaxPermSize=128m.
>>> After I changed them to -Xmx2048m -XX:MaxPermSize=512m , the problem 
>>> went away immediately.
>>> This is on Maven 2.0.7 and Sun JDK 1.5.0_12
>>> Dunno if that will help you at all, but there you go =)
>>> -Erik
>>> Joe Bohn wrote:
>>>> Is nobody else hitting this problem?
>>>>
>>>> Is anybody else building on OpenSUSE?  I have two machines and get 
>>>> hang in the same place on each machine while trying to install the 
>>>> car-maven-plugin.
>>>>
>>>> Even bumping my MAVEN_OPTS to "-XX:MaxPermSize=512m -Xms512m 
>>>> -Xmx1024m" didn't seem to have any effect.
>>>>
>>>> Joe
>>>>
>>>>
>>>> Joe Bohn wrote:
>>>>>
>>>>> I'm consistently hitting a build hang with trunk that I can't get 
>>>>> past.   Is anybody else hitting these problems or does anybody know 
>>>>> what might be going wrong?  Perhaps I need to bump up the MaxPermSize?
>>>>>
>>>>> The build hangs when I get to building the car-maven-plugin.  This 
>>>>> is on  OpenSUSE 10.2 with maven 2.0.7 (although I had the failures 
>>>>> first with 2.0.5 and moving to 2.0.7 didn't change the results) and 
>>>>> Sun JDK 1.5.0_11.
>>>>>
>>>>> My MAVEN_OPTS are set to:
>>>>> "-XX:MaxPermSize=128m -Xms512m -Xmx512m"
>>>>>
>>>>> Here's the last thing I always see:
>>>>> -------------------------------------------------------
>>>>>  T E S T S
>>>>> -------------------------------------------------------
>>>>> Running org.apache.geronimo.mavenplugins.car.PlanProcessorMojoTest
>>>>> Tests run: 2, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.6 
>>>>> sec
>>>>> Running org.apache.geronimo.mavenplugins.car.PluginMetadataTest
>>>>> Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 
>>>>> 0.691 sec
>>>>>
>>>>> Results :
>>>>>
>>>>> Tests run: 3, Failures: 0, Errors: 0, Skipped: 0
>>>>>
>>>>> [INFO] [jar:jar]
>>>>> [INFO] Building jar: 
>>>>> /home/jbohn/geronimo/maven-plugins/car-maven-plugin/target/car-maven-plugin-2.1-SNAPSHOT.jar

>>>>>
>>>>> [INFO] [plugin:addPluginArtifactMetadata]
>>>>> [INFO] [shitty:install {execution: default}]
>>>>> [INFO] Installing 
>>>>> /home/jbohn/geronimo/maven-plugins/car-maven-plugin/target/car-maven-plugin-2.1-SNAPSHOT.jar

>>>>> to 
>>>>> /home/jbohn/.m2/repository/org/apache/geronimo/plugins/car-maven-plugin/2.1-SNAPSHOT/car-maven-plugin-2.1-SNAPSHOT.jar

>>>>>
>>>>>
>>>>
>>
> 
> 

Mime
View raw message