geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lin Sun <linsun....@gmail.com>
Subject Re: [jira] Commented: (GERONIMO-3309) Add missing LICENSE.txt and NOTICE.txt files to the J2G conversion tool
Date Mon, 08 Oct 2007 18:31:12 GMT
Hi Kevan,

Could you try building with mvn install?   I am able to build j2g fine 
with that.

Thanks,

Lin

Kevan Miller wrote:
> 
> On Oct 8, 2007, at 12:53 PM, Jason Warner wrote:
> 
>> It looks like you're building from the ui package.  The ui package has 
>> dependencies on a few other packages in j2g.  The error your getting 
>> is complaining about not being able to find a built version of those 
>> packages.  That error message seems to lack a description of which 
>> package it wants that it can't find.  I took a look at the pom, but 
>> didn't really see anything regarding what packages it would want.  Can 
>> you try building j2g completely from your root j2g directory?  The 
>> same command can be used.
> 
> I'm building from j2g/trunk. The error occurs when the build reaches 
> org.apache.geronimo.j2g.ui.
> 
> Here's output with -e option:
> 
> [INFO] 
> ---------------------------------------------------------------------------- 
> 
> [INFO] Building org.apache.geronimo.j2g.ui
> [INFO] 
> ---------------------------------------------------------------------------- 
> 
> [INFO] [eclipsepde:manifestbundles {execution: default}]
> [INFO] [eclipsepde:install {execution: default}]
> [INFO] org.eclipse.equinox.registry : 3.3.0-v20070522 already exists in 
> local repository.
> [INFO] org.eclipse.ui.console : 3.2.0-v20070530 already exists in local 
> repository.
> [INFO] org.eclipse.jface : 3.3.0-I20070606-0010 already exists in local 
> repository.
> [INFO] SWTFragment:  Dependency {groupId=org.eclipse.plugins, 
> artifactId=org.eclipse.swt.carbon.macosx, version=3.3.0-v3346, type=jar}
> [INFO] org.eclipse.swt.carbon.macosx : 3.3.0-v3346 already exists in 
> local repository.
> [INFO] org.eclipse.swt : 3.3.0-v3346 already exists in local repository.
> [INFO] org.eclipse.equinox.preferences : 3.2.100-v20070522 already 
> exists in local repository.
> [INFO] org.eclipse.ui : 3.3.0-I20070614-0800 already exists in local 
> repository.
> [INFO] org.eclipse.core.jobs : 3.3.0-v20070423 already exists in local 
> repository.
> [INFO] org.eclipse.equinox.app : 1.0.0-v20070606 already exists in local 
> repository.
> [INFO] org.eclipse.core.contenttype : 3.2.100-v20070319 already exists 
> in local repository.
> [INFO] org.eclipse.ui.workbench : 3.3.0-I20070608-1100 already exists in 
> local repository.
> [INFO] org.eclipse.debug.ui : 3.3.0-v20070607-1800 already exists in 
> local repository.
> [INFO] org.eclipse.osgi : 3.3.0-v20070530 already exists in local 
> repository.
> [INFO] org.eclipse.core.runtime : 3.3.100-v20070530 already exists in 
> local repository.
> [INFO] org.eclipse.debug.core : 3.3.0-v20070607-1800 already exists in 
> local repository.
> [INFO] org.eclipse.equinox.common : 3.3.0-v20070426 already exists in 
> local repository.
> [INFO] org.eclipse.swt.carbon.macosx : 3.3.0-v3346 already exists in 
> local repository.
> [INFO] [resources:resources]
> [INFO] Using default encoding to copy filtered resources.
> [INFO] [eclipsepde:validatemanifest {execution: validate-bundle-classpath}]
> [INFO] [compiler:compile]
> [INFO] Nothing to compile - all classes are up to date
> [INFO] [resources:testResources]
> [INFO] Using default encoding to copy filtered resources.
> [INFO] [compiler:testCompile]
> [INFO] No sources to compile
> [INFO] [surefire:test]
> [INFO] No tests to run.
> [INFO] [jar:jar]
> [INFO] Building jar: 
> /Users/kevan/geronimo/devtools/j2g/trunk/plugins/org.apache.geronimo.j2g.ui/target/org.apache.geronimo.j2g.ui-1.0.0-SNAPSHOT.jar

> 
> [INFO] [assembly:assembly]
> [INFO] 
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] Included module: 
> org.apache.geronimo.tools:j2g-plugins:pom:1.0.0-SNAPSHOT does not have 
> an artifact with a file. Please ensure the package phase is run before 
> the assembly is generated.
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] Trace
> org.apache.maven.lifecycle.LifecycleExecutionException: Included module: 
> org.apache.geronimo.tools:j2g-plugins:pom:1.0.0-SNAPSHOT does not have 
> an artifact with a file. Please ensure the package phase is run before 
> the assembly is generated.
>     at 
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:564)

> 
>     at 
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:493)

> 
>     at 
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:463)

> 
>     at 
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:311)

> 
>     at 
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:224)

> 
>     at 
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:143)

> 
>     at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:334)
>     at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:125)
>     at org.apache.maven.cli.MavenCli.main(MavenCli.java:280)
>     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>     at 
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) 
> 
>     at 
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

> 
>     at java.lang.reflect.Method.invoke(Method.java:585)
>     at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>     at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>     at 
> org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>     at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> Caused by: org.apache.maven.plugin.MojoExecutionException: Included 
> module: org.apache.geronimo.tools:j2g-plugins:pom:1.0.0-SNAPSHOT does 
> not have an artifact with a file. Please ensure the package phase is run 
> before the assembly is generated.
>     at 
> org.apache.maven.plugin.assembly.AbstractAssemblyMojo.processModules(AbstractAssemblyMojo.java:520)

> 
>     at 
> org.apache.maven.plugin.assembly.AbstractAssemblyMojo.createArchive(AbstractAssemblyMojo.java:323)

> 
>     at 
> org.apache.maven.plugin.assembly.AbstractAssemblyMojo.createAssembly(AbstractAssemblyMojo.java:261)

> 
>     at 
> org.apache.maven.plugin.assembly.AbstractAssemblyMojo.execute(AbstractAssemblyMojo.java:241)

> 
>     at 
> org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:443)

> 
>     at 
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:539)

> 
>     ... 16 more
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] Total time: 2 minutes 39 seconds
> [INFO] Finished at: Mon Oct 08 13:49:59 EDT 2007
> [INFO] Final Memory: 15M/84M
> [INFO] 
> ------------------------------------------------------------------------
> 
> --kevan
> 
> 


Mime
View raw message