geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Woods <dwo...@apache.org>
Subject Re: [jira] Commented: (GERONIMO-3508) Still cannot build branches/2.0 without building OpenEJB first, due to XBean depends
Date Fri, 05 Oct 2007 20:14:12 GMT
I'm using Maven 2.0.7, Sun 1.5.0_11 on WinXP with a clean .m2 repo in the 
default location.....

Will try it on my SUSE box next to see what happens there....



Joe Bohn (JIRA) wrote:
>     [ https://issues.apache.org/jira/browse/GERONIMO-3508?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12532764
] 
> 
> Joe Bohn commented on GERONIMO-3508:
> ------------------------------------
> 
> I'm not experiencing this same problem.  I've been building geornimo 2.0 without building
openejb 3.0-beta-1 on several linux machines.  Is it possible that this is somehow another
windows only problem?
> 
>> Still cannot build branches/2.0 without building OpenEJB first, due to XBean depends
>> ------------------------------------------------------------------------------------
>>
>>                 Key: GERONIMO-3508
>>                 URL: https://issues.apache.org/jira/browse/GERONIMO-3508
>>             Project: Geronimo
>>          Issue Type: Bug
>>      Security Level: public(Regular issues) 
>>          Components: buildsystem
>>    Affects Versions: 2.0.2
>>            Reporter: Donald Woods
>>            Priority: Blocker
>>             Fix For: 2.0.2
>>
>>
>> Unless you build openejb-3.0-beta-1 first, you will not be able to build Geronimo
2.0.2 (client-corba-yoko config build fails), because of the private xbean revisioned jars
that are referenced by the openejb POM.  The private versions are located by their build by
-
>>     <repository>
>>       <id>openejb-3rdparty-builds</id>
>>       <name>3rd Party Build Repository</name>
>>       <url>http://svn.apache.org/repos/asf/openejb/repo/</url>
>> [INFO] ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Failed to resolve artifact.
>> Missing:
>> ----------
>> 1) org.apache.xbean:xbean-naming:jar:3.2-r579367
>>   Try downloading the file manually from the project website.
>>   Then, install it using the command:
>>       mvn install:install-file -DgroupId=org.apache.xbean -DartifactId=xbean-nam
>> ing \
>>           -Dversion=3.2-r579367 -Dpackaging=jar -Dfile=/path/to/file
>> Alternatively, if you host your own repository you can deploy the file there:
>>     mvn deploy:deploy-file -DgroupId=org.apache.xbean -DartifactId=xbean-naming
>> \
>>           -Dversion=3.2-r579367 -Dpackaging=jar -Dfile=/path/to/file \
>>            -Durl=[url] -DrepositoryId=[id]
>>   Path to dependency:
>>         1) org.apache.geronimo.configs:client-corba-yoko:car:2.0.2-SNAPSHOT
>>         2) org.apache.geronimo.configs:openejb-corba-deployer:car:2.0.2-SNAPSHOT
>>         3) org.apache.geronimo.configs:j2ee-deployer:car:2.0.2-SNAPSHOT
>>         4) org.apache.geronimo.modules:geronimo-client:jar:2.0.2-SNAPSHOT
>>         5) org.apache.geronimo.modules:geronimo-naming:jar:2.0.2-SNAPSHOT
>>         6) org.apache.xbean:xbean-naming:jar:3.2-r579367
>> ----------
>> 1 required artifact is missing.
>> for artifact:
>>   org.apache.geronimo.configs:client-corba-yoko:car:2.0.2-SNAPSHOT
>> from the specified remote repositories:
>>   central (http://repo1.maven.org/maven2),
>>   java.net (http://download.java.net/maven/1/),
>>   apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository),
>>   apache-snapshots (http://people.apache.org/repo/m2-snapshot-repository),
>>   codehaus-snapshots (http://snapshots.repository.codehaus.org),
>>   apache-incubator (http://people.apache.org/repo/m2-incubating-repository/)
> 

Mime
View raw message