geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Warner (JIRA)" <j...@apache.org>
Subject [jira] Updated: (GSHELL-36) The clp does not allow --help to execute if a required argument or option is configured
Date Fri, 26 Oct 2007 03:29:50 GMT

     [ https://issues.apache.org/jira/browse/GSHELL-36?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jason Warner updated GSHELL-36:
-------------------------------

    Attachment: GShell-36.patch

This patch solves the issue that this jira was created for.  You can now use the help option
on commands that have required options without including the required options.  I'm not sure
how elegant this solution is.  I had another idea that involved creating a new field in the
option annotation to act as a flag if the option is for the help command.  I was hesitant
to change an annotation though.  If this would be a more desirable option, let me know and
I'll throw up a new patch that works that way.  Now that I understand what's going on in this
area of the code, that change would be quick and easy.

> The clp does not allow --help to execute if a required argument or option is configured
> ---------------------------------------------------------------------------------------
>
>                 Key: GSHELL-36
>                 URL: https://issues.apache.org/jira/browse/GSHELL-36
>             Project: GShell
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>    Affects Versions: 1.0-alpha-1
>            Reporter: Jason Dillon
>            Assignee: Jason Warner
>             Fix For: 1.0-alpha-1
>
>         Attachments: GShell-36.patch
>
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message