geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Kirby (JIRA)" <>
Subject [jira] Commented: (GERONIMODEVTOOLS-238) Server not found after "Download additional server adapters"
Date Fri, 12 Oct 2007 14:41:50 GMT


Ted Kirby commented on GERONIMODEVTOOLS-238:

For posterity, I wanted to record some things I encountered while working on this problem.

That "Download additional server adapters" function is quirky.

It seems to ignore pre-reqs (the <requires> tag in feature.xml).  So, if the AG 2.0
server adapter requires the AG 1.1 server adapter, the "Download additional server adapters"
function happily allows you to download just the AG 2.0 server adapter.  Although you may
select more than one server adapter to download from the list, it only downloads the first
one selected in the list.  I also know of no way to test this function, other than to deploy
your server adapter to a production site it knows about, and test there.  This is slow, as
deploy to production is slow.  I used the <includes> tag in feature.xml to have the
AG 2.0 server adapter include the AG 1.1 server adapter.  For uninstall to work, I had to
remove the <requires> tags for these server adapters from feature.xml.  It seems with
multiple includes elements, each must have a name, or there are problems processing the file,
and the feature is not shown as being available for download.

> Server not found after "Download additional server adapters"
> ------------------------------------------------------------
>                 Key: GERONIMODEVTOOLS-238
>                 URL:
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Ted Kirby
>            Assignee: Tim McConnell
>             Fix For: 2.0.2
>         Attachments: GD238-2.patch, GD238.patch
> Starting with no geronimo eclipse plugin artifacts installed in my ecplise environment
with all the pre-reqs, I define a new server, then click the "Download additional server adatpers"
link, and install the Geronimo 2.0 Server Adapter.   eclipse restarts, but when I go to define
a new server, Geronimo v2.0 is not in the list of known servers.  I've tried this with the
new WTP2.0.1 all in one package, as well as WTP201 RC1 and RC2 versions.  This used to work
on the RC1 and RC2 versions.  I am not sure what is going on here.
> When I open the Eclipse Error Log view, I get this error:
> eclipse.buildId=M20070905-1045
> java.version=1.5.0_11
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
> Command-line arguments:  -os win32 -ws win32 -arch x86
> Error
> Tue Oct 09 10:08:02 EDT 2007
> Error calling delegate setDefaults() ServerWorkingCopy 10_9_07_10_08_AM0
> java.lang.NullPointerException
> at org.eclipse.jst.server.generic.core.internal.GenericServer.getServerDefinition(
> at org.eclipse.jst.server.generic.core.internal.GenericServer.setDefaults(
> at org.eclipse.wst.server.core.internal.ServerWorkingCopy.setDefaults(
> at org.eclipse.wst.server.core.internal.ServerType.createServer(
> at
> at
> at
> at$1.serverTypeSelected(
> at org.eclipse.wst.server.ui.internal.viewers.ServerTypeComposite$2.selectionChanged(
> at org.eclipse.jface.viewers.Viewer$
> at
> at
> at org.eclipse.ui.internal.JFaceUtil$
> at
> at org.eclipse.jface.viewers.Viewer.fireSelectionChanged(
> at org.eclipse.jface.viewers.StructuredViewer.updateSelection(
> at org.eclipse.jface.viewers.StructuredViewer.setSelection(
> at org.eclipse.jface.viewers.TreeViewer.setSelection(
> at org.eclipse.wst.server.ui.internal.viewers.ServerTypeComposite.setVisible(
> at
> at
> at<init>(
> at org.eclipse.wst.server.ui.internal.wizard.fragment.NewServerWizardFragment.createComposite(
> at org.eclipse.wst.server.ui.internal.wizard.TaskWizardPage.createControl(
> at org.eclipse.wst.server.ui.internal.wizard.TaskWizard.createPageControls(
> at org.eclipse.jface.wizard.WizardDialog.createPageControls(
> at org.eclipse.jface.wizard.WizardDialog.createContents(
> at org.eclipse.jface.window.Window.create(
> at org.eclipse.jface.dialogs.Dialog.create(
> at
> at
> at org.eclipse.jface.action.Action.runWithEvent(
> at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(
> at org.eclipse.jface.action.ActionContributionItem.access$2(
> at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(
> at org.eclipse.swt.widgets.EventTable.sendEvent(
> at org.eclipse.swt.widgets.Widget.sendEvent(
> at org.eclipse.swt.widgets.Display.runDeferredEvents(
> at org.eclipse.swt.widgets.Display.readAndDispatch(
> at org.eclipse.ui.internal.Workbench.runEventLoop(
> at org.eclipse.ui.internal.Workbench.runUI(
> at org.eclipse.ui.internal.Workbench.access$4(
> at org.eclipse.ui.internal.Workbench$
> at org.eclipse.core.databinding.observable.Realm.runWithDefault(
> at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
> at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
> at org.eclipse.ui.internal.ide.application.IDEApplication.start(
> at
> at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
> at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
> at
> at
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> at java.lang.reflect.Method.invoke(Unknown Source)
> at org.eclipse.equinox.launcher.Main.invokeFramework(
> at org.eclipse.equinox.launcher.Main.basicRun(
> at
> in all three cases.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message