geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Gawor" <jga...@gmail.com>
Subject Schema issues
Date Fri, 07 Sep 2007 17:38:01 GMT
I was collecting the different schema files used by Geronimo to
publish them on a web site and I noticed one thing with the
plugins-1.2 xsd. First, it imports attributes-1.1.xsd and not
attributes-1.2.xsd. And that's fine. That's what 2.0.1 came out with.
But in trunk the plugins-1.2.xsd was updated to import
attributes-1.2.xsd. I don't think that is right as it will break
compatibility. I think we should create plugins-1.3.xsd (with -1.3
namespace) which then can import the attributes-1.2.xsd (and switch
the plugins-1.2.xsd to the version in branches/2.0).

I also validated the rest of the .xsd files and for the most part they
validate ok. A few of them ( geronimo-web-2.0.xsd,
geronimo-jetty-2.0.xsd, and geronimo-tomcat-2.0.xsd) import
persistence-1.0.xsd as a local file. I can't find that file anywhere
in Geronimo. Should I update these Geronimo .xsd files to refer to
http://java.sun.com/xml/ns/persistence/persistence_1_0.xsd or should
we pull it in locally?

Jarek

Mime
View raw message