geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shiva Kumar H R" <shiv...@gmail.com>
Subject Re: [DISCUSS] Release Geronimo Eclipse Plugin 2.0.0 (RC2)
Date Fri, 14 Sep 2007 17:04:41 GMT
On 9/14/07, Lin Sun <linsun.unc@gmail.com> wrote:
>
> Tim, thanks for your nice instruction.  I am able to do scenario 2 fine
> without any prob!
>
> I have noticed 2 things:
>
> 1) one other recommended scenario (may be the most recommended scenario)
> used to be not download anything, but start at define a server then
> choose the link called "download additional server adapters" when a user
> doesn't see the adapter he wants there.   From the resulting page, he
> can just download the geronimo eclipse plugin.   I don't know if you or
> anyone has worked with WTP team to get our geronimo server to be on the
> list?
>
> 2) I tried to deploy a hello war project and able to deploy fine.   But
> right click the project and do a run as, run on server doesn't bring up
> the eclipse internal web browser automatically.   I wonder if someone
> else has noticed this?


Yes! there seems to be a problem. I tried these:
a) Created a dynamic web project and then added an index.jsp. Right click on
the index.jsp file and select "Run As -> Run on Server". Everything worked
fine including the internal web browser getting opened with the URL of
index.jsp!

An important thing to note here is that the "geronimo-web.xml" that got
created was using 1.1 version of Geronimo schemas as shown below:
<web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1" xmlns:nam="
http://geronimo.apache.org/xml/ns/naming-1.1" xmlns:sec="
http://geronimo.apache.org/xml/ns/security-1.1" xmlns:sys="
http://geronimo.apache.org/xml/ns/deployment-1.1">

b) I now changed the schema versions in "geronimo-web.xml" as below:
<web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-2.0" xmlns:nam="
http://geronimo.apache.org/xml/ns/naming-1.2" xmlns:sec="
http://geronimo.apache.org/xml/ns/security-2.0" xmlns:sys="
http://geronimo.apache.org/xml/ns/deployment-1.2">

When I now right click on the same "index.jsp" and select "Run As -> Run on
Server" I see that the internal web browser is *not* getting opened.

I see the same behaviour (as described in a) & b) above) with both WTP 2.0 &
WTP 2.0.1RC1.

- Shiva

Lin
>
>
> Tim McConnell wrote:
> > Start of discussion thread.....
>
>

Mime
View raw message