geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shiva Kumar H R" <shiv...@gmail.com>
Subject Re: [VOTE] Release Geronimo Eclipse Plugin 2.0.0
Date Fri, 07 Sep 2007 18:24:05 GMT
+1 provided we mention in the Release notes that 2.0 Geronimo deployment
plans are not yet supported (GERONIMODEVTOOLS-190).

Tested as per the article http://cwiki.apache.org/confluence/x/MQAB and
there are no blockers :-) . Below are more observations:

1) While adding Geronimo v2.0.1 server, it throws a warning saying:
"A geronimo installation was detected, however the version could not be
verified."

2) Starting the server for the first time (typically after a system restart)
fails as reported in GERONIMODEVTOOLS-193. Trying to start for the second
time has always succeeded.

3) While creating a new Dynamic Web Project, "Geronimo Deployment" version
is shown as "1.1" where it is expected to be "v2.0". Hence the initial "
geronimo-web.xml" that is created uses "web-1.1", "naming-1.1" etc instead
of web-2.0, naming-1.2 etc. Same with new EJB projects and others. The
created projects still run fine, as Geronimo 2.0.1 accepts v1.1 plans
without any errors.

4) While creating an EAR project, WTP 2.0 didn't auto create "
application.xml" and when tried to deploy such an EAR (without "
application.xml") deployment failed. Need to figure out if it's a bug in WTP
or a limitation in Geronimo.

5) "persistence.xml" created using DTP wizard, can't be edited sometimes and
needs a restart of Eclipse. Looks to be an issue in WTP. Need to raise a
WTP-bug for this.

Thanks,
Shiva

On 9/6/07, Tim McConnell <tim.mcconne@gmail.com> wrote:
>
> Hi Matt, to address the problems you've encountered I've done a number of
> things
> to hopefully ease the effort required to review and test the plugin:
>
> 1 -- There is now a rudimentary set of install instructions available at
> the url
> below that will hopefully describe the necessary prereqs and steps
> required to
> install and run the plugin. I'm in the process of creating Wiki pages for
> the
> Plugin Release Process and General Information about the plugin, and would
> like
> to use this document as a base for the General Information page. So, I
> would be
> very interested in getting feedback on these instructions:
>
>
> http://people.apache.org/~mcconne/releases/Geronimo_Eclipse_Plugin_2.0_Instructions.txt
>
> 2 -- There is now an ant build.xml file that can be used to download all
> the
> prereqs for the plugin. It is documented in the instructions.
>
> 3 -- Per numerous recommendations, I've created a Staging Site that used
> to test
> the update manager functions of Eclipse for downloading both the plugin
> itself
> and the Geronimo Server. This is also documented in the instructions.
>
> Hopefully, these will help. If not just let me know. The vote will now
> conclude
> at 8:00 AM EST Sunday September 9th. Thanks much
>
>
> Tim McConnell wrote:
> > Hi, Please review and vote on the release of the Geronimo Eclipse Plugin
> > 2.0.0 (to correspond with the Geronimo 2.0.1 Server release):
> >
> > The deployable zip file is here:
> >
> > ---->
> >
> http://people.apache.org/~mcconne/releases/g-eclipse-plugin-2.0.0-deployable.zip
> >
> >
> > The current svn location is here:
> >
> > ---->
> >
> https://svn.apache.org/repos/asf/geronimo/devtools/eclipse-plugin/branches/2.0.0
> >
> >
> > The future svn location will be here:
> >
> > ---->
> >
> https://svn.apache.org/repos/asf/geronimo/devtools/eclipse-plugin/tags/2.0.0
> >
> >
> > The vote will conclude at 2:00 PM EST on Thursday, September 6th.
> >
>
> --
> Thanks,
> Tim McConnell
>

Mime
View raw message