geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shiva Kumar H R (JIRA)" <>
Subject [jira] Created: (GERONIMODEVTOOLS-204) Change pre-requisite from current "wtp-all-in-one-sdk-* (266MB)" to "Eclipse IDE for Java EE Developers (125MB)"
Date Thu, 13 Sep 2007 15:24:32 GMT
Change pre-requisite from current "wtp-all-in-one-sdk-* (266MB)" to "Eclipse IDE for Java EE
Developers (125MB)"

                 Key: GERONIMODEVTOOLS-204
             Project: Geronimo-Devtools
          Issue Type: New Feature
          Components: eclipse-plugin
    Affects Versions: 2.1
            Reporter: Shiva Kumar H R
             Fix For: 2.1

Geronimo Eclipse Plug-in (GEP) v2.0 currently has following pre-requisites:
1 -- Eclipse Classic 3.3
2 -- Web Tools Platform (WTP) 2.0
3 -- Data Tools Platform (DTP) 1.5
4 -- Eclipse Modeling Framework (EMF) 2.3
5 -- Graphical Editing Framework (GEF) 3.3

A wtp-all-in-one-sdk-* bundle that includes all the above 5 pre-requisites can be downloaded
and it has a size of around 260MB. starting with Europa release ( have a new package
by name "Eclipse IDE for Java EE Developers" with a size of just "125MB" (no source bundles
included) and has all the pre-requistes for GEP.

GEP should be updated to utilize this new package of smaller download size.

(This was attempted in GERONIMODEVTOOLS-180 and due to some problems faced, this has been
deferred to GEP 2.1).

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message