geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim McConnell (JIRA)" <j...@apache.org>
Subject [jira] Updated: (GERONIMODEVTOOLS-209) Hello World JSP does not open in Eclipse browser when invoked with "run as, run on server" from within Eclipse
Date Sat, 15 Sep 2007 01:38:32 GMT

     [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-209?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tim McConnell updated GERONIMODEVTOOLS-209:
-------------------------------------------

          Description: 
This appears to be a WTP 2.0.x bug, not a problem with the Eclipse plugin. The Eclipse plugin
is passing a valid HttpLaunchable object, with the correct url, to the WTP web client launcher
class ([org.eclipse.wst.server.ui.web). But when it is ultimately ready to be launched that
launchable object is null causing a NPE (stack trace below). Moving the JIRA to 2.1, and will
open a bugzilla report against WTP 2.0.x.

java.lang.NullPointerException
	at org.eclipse.wst.server.ui.internal.WebLaunchableClient.launch(WebLaunchableClient.java:39)
	at org.eclipse.wst.server.core.internal.Client.launch(Client.java:114)
	at org.eclipse.wst.server.ui.internal.LaunchClientJob$1.run(LaunchClientJob.java:79)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3659)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3296)
	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2389)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2353)
	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2219)
	at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:289)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:461)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:106)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1148)

 
    Affects Version/s:     (was: 2.0)
                       2.1
        Fix Version/s:     (was: 2.0)
                       2.1

> Hello World JSP does not open in Eclipse browser when invoked with "run as, run on server"
from within Eclipse
> --------------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-209
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-209
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 2.1
>            Reporter: Tim McConnell
>            Assignee: Tim McConnell
>             Fix For: 2.1
>
>
> This appears to be a WTP 2.0.x bug, not a problem with the Eclipse plugin. The Eclipse
plugin is passing a valid HttpLaunchable object, with the correct url, to the WTP web client
launcher class ([org.eclipse.wst.server.ui.web). But when it is ultimately ready to be launched
that launchable object is null causing a NPE (stack trace below). Moving the JIRA to 2.1,
and will open a bugzilla report against WTP 2.0.x.
> java.lang.NullPointerException
> 	at org.eclipse.wst.server.ui.internal.WebLaunchableClient.launch(WebLaunchableClient.java:39)
> 	at org.eclipse.wst.server.core.internal.Client.launch(Client.java:114)
> 	at org.eclipse.wst.server.ui.internal.LaunchClientJob$1.run(LaunchClientJob.java:79)
> 	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
> 	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
> 	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3659)
> 	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3296)
> 	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2389)
> 	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2353)
> 	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2219)
> 	at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
> 	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:289)
> 	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:461)
> 	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
> 	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:106)
> 	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)
> 	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)
> 	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)
> 	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
> 	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> 	at java.lang.reflect.Method.invoke(Unknown Source)
> 	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
> 	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
> 	at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
> 	at org.eclipse.equinox.launcher.Main.main(Main.java:1148)
>  

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message