geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ramesh B (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-3450) Unable to Run Pluto 1.1 on Geronimo 2.0
Date Fri, 31 Aug 2007 04:10:31 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-3450?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12523995
] 

Ramesh B commented on GERONIMO-3450:
------------------------------------

Hi Kevan,
Many thanks for the help... i've been struggling with this for days.
The reason why i had filtered org.apache.pluto was this comes by default with geronimo and
i didn't want to use these jars. I had added these jars seperately in the web-inf/lib folder
of the war.
The pluto portal has successfully deployed after implementing your suggestion. thanks again
for the help.

Regards,
Ramesh B.

> Unable to Run Pluto 1.1 on Geronimo 2.0
> ---------------------------------------
>
>                 Key: GERONIMO-3450
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-3450
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: deployment
>    Affects Versions: 2.0-M2
>         Environment: Operating System : Windows 2k3
> Pluto Version: 1.1.0
> Geronimo with Jetty Version  	2.0.1 
>            Reporter: Ramesh B
>             Fix For: 1.1.2, 1.1.x
>
>         Attachments: geronimo-web.xml, geronimo.log
>
>
> Hi,
> I'm new to geronimo webserver. I've been trying to deploy pluto 1.1 on geronimo with
jetty 2.0.1.
> For this I have done the following steps:
> 1) I've added the following additional jars to common libs before deployment:
>     *  pluto-container-1.1.0.jar
>     * pluto-descriptor-api-1.1.0.jar
>     * pluto-descriptor-impl-1.1.0.jar
>     * pluto-taglib-1.1.0.jar
>     * xalan 2.6.0
> 2) I've modified the castor.properties for pluto/web-inf/classes and set all parameters
to false.
> 3) i've added a geronimo-web.xml to the /web-inf folder.
> I created a war of the pluto folder. however while deploying it it gives the following
error:
> 3582: 11:02:34,501 ERROR [log] Nested in org.springframework.beans.factory.BeanDefinitionStoreException:
Unexpected exception parsing XML document from ServletContext resource [/WEB-INF/pluto-portal-driver-services-config.xml];
nested exception is java.lang.IllegalArgumentException: Class [org.apache.cxf.clustering.spring.NamespaceHandler]
does not implement the NamespaceHandler interface:
> After throwing this error on the console it shows as successfully deployed and successfully
running.
> However when i'm trying to access the pluto portal, it says service unavailable.
> Please help me with this problem.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message