geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ajay Panagariya" <apana...@gmail.com>
Subject Problem exporting a plugin and importing it into minimal assembly
Date Fri, 06 Jul 2007 13:58:41 GMT
Hi,

I'm trying to export a plugin from the full assembly (activemq broker in
this case) and then import it into the minimal assembly of Geronimo. Below
is what I typed into the console and the resulting output. I'm not completly
sure how to debug this (I tried running Geronimo in debug mode and placing
breakpoints in CommandCARInstaller.java (that's where the Installation
FAILED message is generated), but it never stops at those breakpoints. So
then I tried to run deployer.jar in Eclipse's debugger (which I was unable
to get working after spending a significant amount of time trying different
configurations).

$ target/geronimo-tomcat6-minimal-2.0-SNAPSHOT/bin/deploy.bat install-plugin
amq.car
Using GERONIMO_BASE:   C:\g\target\geronimo-tomcat6-minimal-2.0-SNAPSHOT
Using GERONIMO_HOME:   C:\g\target\geronimo-tomcat6-minimal-2.0-SNAPSHOT
Using GERONIMO_TMPDIR: var\temp
Using JRE_HOME:        C:\Program Files\Java\jdk1.5.0_12\jre
Checking for status every 1000ms:
Installation FAILED: null

I'm at a loss at why first why it fails, and second why it fails in the way
it does. Below is the geronimo-plugin.xml

<?xml version="1.0" encoding="UTF-8"?>
<geronimo-plugin xmlns="http://geronimo.apache.org/xml/ns/plugins-1.2">
<name>org.apache.geronimo.configs/activemq-broker/2.0-SNAPSHOT/car</name>
<module-id>org.apache.geronimo.configs
/activemq-broker/2.0-SNAPSHOT/car</module-id>
<category>Unknown</category>
<description>Please provide a description</description>
<url></url>
<author></author>
<dependency>org.apache.geronimo.configs/system-database//car</dependency>
<dependency>org.apache.geronimo.modules
/geronimo-activemq/2.0-SNAPSHOT/jar</dependency>
<dependency>org.apache.geronimo.modules
/geronimo-activemq-management/2.0-SNAPSHOT/jar</dependency>
<dependency>org.apache.activemq/activemq-core/4.1.1/jar</dependency>
<dependency>org.apache.activemq
/activeio-core/3.0.0-incubator/jar</dependency>
<dependency>backport-util-concurrent/backport-util-concurrent/2.2/jar</dependency>
<obsoletes>org.apache.geronimo.configs/activemq-broker//car</obsoletes>
</geronimo-plugin>

I was under the impression Geronimo's installation process should find all
the dependencies and handle them during installation. Is this incorrect?

-Ajay

Mime
View raw message