geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Petersson <pe...@pmb.mine.nu>
Subject Apache Roller v4.0 plugin
Date Wed, 18 Jul 2007 00:03:05 GMT
david jencks wrote:
> We should move this discussion to the dev list I think, you can quote 
> or copy anything I've written to the dev list.
Just did ;)
>
> It looks like we collided on this work :-)     I haven't had 
> consistent internet access for the last few days (my dsl just got 
> connected an hour ago) so I haven't done a good job of keeping you up 
> to date with my progress.
np
>
> I just committed some changes to geronimo/roller that, together with 
> ROL-1482, get roller working for me on geronimo-jetty.  I haven't 
> looked at your patch.
Great ! I will check out your changes and if I find anything to add from 
my resent patch I will let you know.
>
> - I got the security realm gbean to work.  I doubt it is needed since 
> IIUC roller is using acegi and I don't think it is hooked up to javaee 
> security.
> - I got the database initialization gbean  to work by tweaking the 
> openjpa schema synchronization properties.  I'm not sure that having 
> openjpa create all the tables will end up with enough indexes, and 
> without more info in the orm.xml files the columns will be 
> dramatically different sizes..  For instance, the primary key id 
> columns appear to be 48 characters to accomodate a UUID, but openjpa 
> want to make the 255 characters.  On the other hand it looks like 
> roller can be set to create the tables itself or even upgrade from 
> previous schemas, so maybe we should try to enable that feature 
> instead of running our own script.  If we can enable this feature I 
> think we can drop the roller-*-resources modules.
Yes I noticed roller was attempting to upgrade the db on some of my 
installation tests but at the moment it appears to be a bit jumpy. I 
agree it would be preferable to let roller handle the upgrade and 
installation.
> - I will look at the tomcat/jasper problem you show below but I 
> suspect that it's caused by not including the jasper builder in the 
> car-maven-plugin configuration.  I think I fixed this in both versions 
> but I haven't actually tried running the tomcat version yet.
>
> - I added a "top level build" that seems to work ok but only after 
> I've built each  module separately once.  I don't understand why this 
> is happening.
As did I (its in the patch) when I got tired of building the modules 
separately. I got the exact same problem it seems maven picks the 
modules in alphabetic order I thought maven would be able to find out 
the right (dependency) order (someone probably know the trick).
>
>
> It was very exciting to get roller to finally run on my machine after 
> months of struggle!
I know the feeling from G v1.1 and v1.2 :) . Now we can focus on getting 
things stable and hopefully into a public "Gplugin" repository soon 
after the G v2.0 release.
>
> I think we should ask roller to publish some usable artifacts to the 
> maven repo using the ant maven tasks.  Then we won't have to do this 
> silly unpacking the zip routine. 

I agree go ahead and drop something in there dev list 
http://cwiki.apache.org/confluence/display/ROLLER/Roller+Mailing+Lists

> Many many thanks!
> david jencks 
Sry if this turns out to be a double post (I was posting from my gmail 
account)

thanks
 Peter Petersson

Mime
View raw message