geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sachin Patel (JIRA)" <j...@apache.org>
Subject [jira] Closed: (GERONIMODEVTOOLS-142) g-eclipse-plugin 1.2.1 requires the feature "org.eclipse.jst 1.5.3".
Date Mon, 02 Jul 2007 17:36:04 GMT

     [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-142?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sachin Patel closed GERONIMODEVTOOLS-142.
-----------------------------------------

    Resolution: Won't Fix

It does require 1.5.3.  There were some fixes that went into WTP 1.5.3 that are needed.  (Its
been a long time and I can't remember exactly what those fixes where but had to do with the
installable runtime/server support.) You may get the deployable.zip for the 1.2.1 plugin,
and it will install but you may run into minor issues.  Thus the update manager distribution
was restricted to require 1.5.3.

> g-eclipse-plugin 1.2.1 requires the feature "org.eclipse.jst 1.5.3".
> --------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-142
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-142
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 1.2.1
>            Reporter: Kan Ogawa
>            Priority: Critical
>         Attachments: screenshot-1.jpg
>
>
> Now, using the following Eclipse environment, I am developing the J2EE application with
Apache Geronimo server.
>  (a) Eclipse 3.2.1 with Language Pack.
>  (b) Eclipse WTP 1.5.1 with Language Pack.
>  (c) Apache Geronimo Server 1.2.0 beta (in the future, I will upgrade to its stable release.)
>  (d) Geronimo WTP Server Adapter plug-in 1.2.1 (2007/04/03 Build, I built it by maven
after downloading the source codes from the apache svn repository.)
> In this environment, Eclipse always displays the error message, which it cannot install
any and every plugins from any and every update sites(in other words, any other plugin except
g-eclipse-plugin).
> (See the attached screen shot.)
> In order to compile and run g-eclipse-plugin 1.2.1, is the feature "org.eclipse.jst 1.5.3"
required absolutely?
> That is, does g-eclipse-plugin 1.2.1 not run on the older version (from JST 1.5.0 to
1.5.2 version) than JST 1.5.3?
> I doesn't have verified all features in g-eclipse-plugin 1.2.1 yet, but I got the impression
that it is running in the above eclipse environment (a) and (b).
> Now, on the eclipse error log view, the error level messages display none.
> If it can run on the older version than Eclipse JST 1.5.3, can you modify the "requires"
element definition in feature.xml?
> [Before]
>    <requires>
>       <import feature="org.eclipse.jst" version="1.5.3" match="compatible"/>
>    </requires>
> [After]
>    <requires>
>       <import feature="org.eclipse.jst" version="1.5.0" match="compatible"/>
>    </requires>
> If it cannot certainly run the older version its 1.5.3, would you give a detail of the
reason?
> Best Regards,
> Kan Ogawa

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message