geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Dmitriev (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (GERONIMODEVTOOLS-145) Provide WTP2.0.x compatibility
Date Tue, 24 Jul 2007 05:43:31 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-145?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12514855
] 

Vadim Dmitriev edited comment on GERONIMODEVTOOLS-145 at 7/23/07 10:43 PM:
---------------------------------------------------------------------------

Dependency on JST1.6.0 still exists in july 03/july 24 builds.
>From feature.xml of org.apache.geronimo.v20.feature_2.0.0 (same for v11 and v10):
    <requires>
        <import feature="org.eclipse.jst" version="1.6.0" match="compatible"/>
    </requires>

Changing version to "2.0.0" seems resolve the issue with using eclipse updater ( "Geronimo
v1.0 Server Adapter (2.0.0) requires feature "org.eclipse.jst (1.6.0)", or compatible." )

P.S. misspelled "JST" as "JDT" in issue description, sorry.


 was:
Dependency on JST1.6.0 still exists in july 03/july 24 builds.
>From feature.xml of org.apache.geronimo.v20.feature_2.0.0 (same for v12 and v11):
    <requires>
        <import feature="org.eclipse.jst" version="1.6.0" match="compatible"/>
    </requires>

Changing version to "2.0.0" seems resolve the issue with using eclipse updater ( "Geronimo
v1.0 Server Adapter (2.0.0) requires feature "org.eclipse.jst (1.6.0)", or compatible." )

P.S. misspelled "JST" as "JDT" in issue description, sorry.

> Provide WTP2.0.x compatibility
> ------------------------------
>
>                 Key: GERONIMODEVTOOLS-145
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-145
>             Project: Geronimo-Devtools
>          Issue Type: Task
>          Components: eclipse-plugin
>    Affects Versions: 2.0
>         Environment: Eclipse3.3, WTP2.0.1
>            Reporter: Vadim Dmitriev
>            Assignee: Sachin Patel
>            Priority: Minor
>
> WTP2.0 prior to m6 release had most of included plugins with version 1.6.0. Since m6
these plugins version was changed to 2.0.
> In this case dependency on JDT 1.6.0 can't be satisfied on WTP2.0m6 or later.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message