geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kan Ogawa (JIRA)" <>
Subject [jira] Updated: (GERONIMODEVTOOLS-142) g-eclipse-plugin 1.2.1 requires the feature "org.eclipse.jst 1.5.3".
Date Tue, 17 Apr 2007 06:52:15 GMT


Kan Ogawa updated GERONIMODEVTOOLS-142:

    Attachment: screenshot-1.jpg

> g-eclipse-plugin 1.2.1 requires the feature "org.eclipse.jst 1.5.3".
> --------------------------------------------------------------------
>                 Key: GERONIMODEVTOOLS-142
>                 URL:
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 1.2.1
>            Reporter: Kan Ogawa
>         Attachments: screenshot-1.jpg
> Now, using the following Eclipse environment, I am developing the J2EE application with
Apache Geronimo server.
>  (a) Eclipse 3.2.1 with Language Pack.
>  (b) Eclipse WTP 1.5.1 with Language Pack.
>  (c) Apache Geronimo Server 1.2.0 beta (in the future, I will upgrade to its stable release.)
>  (d) Geronimo WTP Server Adapter plug-in 1.2.1 (2007/04/03 Build, I built it by maven
after downloading the source codes from the apache svn repository.)
> In this environment, Eclipse always displays the error message, which it cannot install
any and every plugins from any and every update sites(in other words, any other plugin except
> (See the attached screen shot.)
> In order to compile and run g-eclipse-plugin 1.2.1, is the feature "org.eclipse.jst 1.5.3"
required absolutely?
> That is, does g-eclipse-plugin 1.2.1 not run on the older version (from JST 1.5.0 to
1.5.2 version) than JST 1.5.3?
> I doesn't have verified all features in g-eclipse-plugin 1.2.1 yet, but I got the impression
that it is running in the above eclipse environment (a) and (b).
> Now, on the eclipse error log view, the error level messages display none.
> If it can run on the older version than Eclipse JST 1.5.3, can you modify the "requires"
element definition in feature.xml?
> [Before]
>    <requires>
>       <import feature="org.eclipse.jst" version="1.5.3" match="compatible"/>
>    </requires>
> [After]
>    <requires>
>       <import feature="org.eclipse.jst" version="1.5.0" match="compatible"/>
>    </requires>
> If it cannot certainly run the older version its 1.5.3, would you give a detail of the
> Best Regards,
> Kan Ogawa

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message