geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: Seeing trunk build error after recent changes to remove backport-util-concurrent
Date Mon, 26 Mar 2007 20:22:15 GMT
Chances are you have an old xbean-naming 3.0-SNAPSHOT.  This weekend  
xbean/trunk was moved to build with Java 5 and the backport jar was  
dropped as a dependency.  I published new snaps right after the  
change was made.

Though David Jencks did bring up a point about backport being needed  
on the client's config anyways if some jms muck was needed, so  
perhaps we need to add it back to the client car, but it shouldn't be  
needed for rmi-naming anymore for sure.

--jason


On Mar 26, 2007, at 1:12 PM, Donald Woods wrote:

> Trying to build trunk Rev522511 on WinXP with a clean .m2 repo and  
> getting the following error -
>
> [INFO]---------------------------------------------------------------- 
> ------------
> [INFO] Building Geronimo Configs :: RMI Naming
> [INFO]    task-segment: [install]
> [INFO]---------------------------------------------------------------- 
> ------------
> . . . <snip>
> [INFO]---------------------------------------------------------------- 
> --------
> [ERROR] BUILD ERROR
> [INFO]---------------------------------------------------------------- 
> --------
> [INFO] org.apache.geronimo.gbean.InvalidConfigurationException:  
> Could not find getGBeanInfo method on  
> org.apache.geronimo.gjndi.GlobalContextGBean
> edu/emory/mathcs/backport/java/util/concurrent/locks/Lock
>
>
> Adding backport-util-concurrent back into configs/rmi-naming/ 
> pom.xml fixes this build failure, but then the J2EE Client config  
> fails for the same reason....
>
> Is anyone else seeing this build failure???
>
>
> -Donald


Mime
View raw message