geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: What is the Java Version for building source code?
Date Fri, 30 Mar 2007 22:13:39 GMT
Are you using the latest code from server/trunk?  I updated the build  
last night to use a previous snapshot version of the maven-enforcer- 
plugin to get around this problem until Brian can fix the issue with  
the plugin.  With the latest in server/trunk you should *not* see  
this problem.

--jason


On Mar 30, 2007, at 3:07 PM, Niklas Gustavsson wrote:

> Lasantha Ranaweera wrote:
>> Hi,
>> What is the recommended Java version to be used with building G  
>> from source code?
>> At the moment I am having a problem of building G from source code  
>> (maven build fails with complaining incompatible Java version).
>
> I'm running into the same issue with 1.5.0_05. This makes for an  
> odd error message:
>
> [INFO] [enforcer:enforce {execution: default}]
> [INFO] Detected Maven Version: 2.0.5 is allowed in the range [2.0.5,).
> [WARNING] Rule 0: RequireJavaVersion failed with message: Detected  
> JDK Version:
> 1.5.0-05 is not in the allowed range [1.5,1.6).
>
> Changing the range to [1.4,1.6) let's me pass but that's probably  
> not a good idea ;-)
>
> /niklas
>


Mime
View raw message