geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Using alternate .xsd files with PluginInstallerGBean
Date Wed, 28 Mar 2007 12:09:21 GMT
well, if you look at PluginInstallerGBean.createDocumentBuilder  
line1307, you'll see that it's going to use a file /META-INF/schema/ 
plugins-1.1.xsd located in the classpath.

I think you'll need to rebuild the system module replacing  
plugins-1.1.xsd with your version or make a new gbean in a module  
with your schema in the classpath, with  your schema named something  
else than plugins-1.1.xsd..... maybe plugins-1.2.xsd :-)

thanks
david jencks

On Mar 28, 2007, at 1:33 AM, Jason Warner wrote:

> I'm trying to use an alternate version of the plugins-1.1.xsd in  
> testing a improvement I've been working on for the  
> PluginInstallerGBean.  I am having trouble getting geronimo to use  
> that one.  I'm not sure how to tell Geronimo to look at a different  
> source for its .xsd needs.  I am able to host the files myself so  
> that isn't an issue.  Anyone have any ideas?


Mime
View raw message