geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Qiu" <sean.xx....@gmail.com>
Subject [test]-build error of webservices-testsuite
Date Fri, 09 Mar 2007 06:58:56 GMT
Os: Redhat
Revision: 516311

After successfully build the geronimo, i want to run the testsuite of it.
I have successfull run the other 4 module of testsuite and get the
report as below(skip webservices)

Package	Tests	Errors 	Failures	Skipped	Success Rate	Time
enterprise-testsuite#	39	30	0	0	23.077%	147.958
web-testsuite#	18	1	4	0	72.222%	126.882
console-testsuite#	40	0	0	0	100%	275.764
deployment-testsuite#	7	0	0	0	100%	68.137

But unfortunately, the webservices-testsuite still failed.
===================================
[INFO] [INFO] Distributing module artifact:
/home/sean/trunk/testsuite/webservices-testsuite/jaxws-tests/jaxws-client/target/jaxws-client-2.0-SNAPSHOT.jar
with plan null
[WARNING] Deployer operation failed: No JAX-WS ServiceRefBuilders registered
[WARNING] org.apache.geronimo.common.DeploymentException: No JAX-WS
ServiceRefBuilders registered
....
[WARNING]       at
sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
[WARNING]       at java.lang.Thread.run(Thread.java:595)
[INFO] [WARNING] Ignoring failure !
[INFO] [INFO] [geronimo:run-client {execution: run-client}]
[INFO] [INFO] Geronimo Home:
/home/sean/trunk/testsuite/webservices-testsuite/target/geronimo-jetty6-jee5-2.0-SNAPSHOT
[INFO] [INFO] Starting Geronimo client...
[INFO] [INFO] Redirecting output to:
/home/sean/trunk/testsuite/webservices-testsuite/jaxws-tests/jaxws-client/target/client.log
[INFO] [INFO] ------------------------------------------------------------------------
[INFO] [ERROR] BUILD ERROR
[INFO] [INFO] ------------------------------------------------------------------------
[INFO] [INFO] Java returned: 2
[INFO]
[INFO] [INFO] ------------------------------------------------------------------------
[INFO] [INFO] Trace
[INFO] org.apache.maven.lifecycle.LifecycleExecutionException: Java returned: 2
[INFO]  at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:564)
[INFO]  at ....

[INFO] [INFO] ------------------------------------------------------------------------
[INFO] [INFO] Total time: 27 seconds
[INFO] [INFO] Finished at: Fri Mar 09 14:50:36 CST 2007
[INFO] [INFO] Final Memory: 21M/508M
[INFO] [INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] exec returned: 1

[INFO] ------------------------------------------------------------------------
[INFO] Trace
org.apache.maven.lifecycle.LifecycleExecutionException: exec returned: 1
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:564)
....
===========================
And in the log file
webservices-testsuite/jaxws-tests/jaxws-client/target/client.log, the
message is :
===========================
17:52:54,538 INFO  [Log4jService] ----------------------------------------------
org.apache.geronimo.kernel.config.LifecycleException: load of
JEE5/JAXWSClient/1.1/car failed
        at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConfiguration(SimpleConfigurationManager.java:274)
        at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConfiguration(SimpleConfigurationManager.java:253)
        at org.apache.geronimo.kernel.config.KernelConfigurationManager.loadConfiguration(KernelConfigurationManager.java:112)
        at org.apache.geronimo.gbean.runtime.FastMethodInvoker.invoke(FastMethodInvoker.java:38)
=======================

Is there any good solution to find out what happened? Then i can debug
myself, thanks.
-- 
Sean Qiu

Mime
View raw message