geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hernan Cunico <hcun...@gmail.com>
Subject Re: DB Viewer portlet error
Date Thu, 29 Mar 2007 15:51:42 GMT
If it helps, I just tried with an external DB and it works. I can create and test a connection
pool (just like before) and also access it via an application.
This seems to be just around the embedded Derby.

Cheers!
Hernan

Hernan Cunico wrote:
> I can deploy the pool just fine but it is the DB creation process the 
> one I have no control.
> I use the DB manager to create a new DB, that DB is listed in the DB 
> Viewer portlet, when I click that DB I get this error. At this point I 
> only entered the name of a new DB I wanted to create, the rest is just 
> "mouse" clicks ;-)
> 
> So, when I get the portlet error (still in the DB Manager) I check the 
> logs and see the "...java.sql.SQLException: No suitable driver ..."
> 
> If I create a connection pool, I will still be able to test the 
> connection (at creation time) and deploy the pool via console (have not 
> tried via command line yet). The pool gets successfully deployed but 
> when I try to access that DB I get a weird error, like the DB does not 
> exist. So this is kind of a second test to see if I can still access the 
> DB (which I can't) but the main issue is that the DB Viewer portlet 
> cannot display any DB content for other than the "SystemDatabase".
> 
> Cheers!
> Hernan
> 
> David Jencks wrote:
>> Did you specify to include the appropriate derby jars as dependencies 
>> when you created the module?  The tranql connectors don't include the 
>> derby jars you need, you have to depend on them for each db pool you 
>> set up.
>>
>> thanks
>> david jencks
>>
>> On Mar 29, 2007, at 7:22 AM, Hernan Cunico wrote:
>>
>>> Hi All,
>>> Just wondering if somebody else is seeing this problem. I create a 
>>> new DB with the DB manager and the DB is created successfully but 
>>> when I try to view that DB from the DB Viewer I get a portlet error.
>>>
>>> When I check the logs I get this:
>>>
>>> 09:57:02,421 ERROR [listTables_jsp]] Servlet.service() for servlet 
>>> jsp.WEB_002dINF.view.internaldb.listTables_jsp threw exception
>>> javax.servlet.ServletException: javax.servlet.jsp.JspTagException: 
>>> Error getting connection: "java.sql.SQLException: No suitable driver"
>>> ...
>>> 09:57:02,421 ERROR [[DBViewer]] Servlet.service() for servlet 
>>> DBViewer threw exception
>>> javax.servlet.ServletException
>>> ...
>>> 09:57:02,453 ERROR [PortletInvokerImpl] PortletInvokerImpl.render() - 
>>> Error while dispatching portlet.
>>> javax.portlet.PortletException
>>> ...
>>>
>>> One interesting this is that I can still create a pool connection and 
>>> test it (at creation time). But when I try to access that DB from an 
>>> app I also get a connection error
>>>
>>> ResourceAllocationException: Unable to obtain physical connection to 
>>> jdbc:derby:TestDB
>>>
>>> This is on the M4 branch, any ideas?
>>>
>>> Cheers!
>>> Hernan
>>
>>
> 

Mime
View raw message