geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hernan Cunico <hcun...@gmail.com>
Subject Re: why do we call the "eclipse plugin" devtools?
Date Wed, 07 Mar 2007 18:21:32 GMT
This is more a organizational kind of question. 

How should we maintain the eclipse-plugin specific content (other than eclipse-plugin.html
that could be in the root dir).
There is currently a devtools directory that contains some eclipse-plugin related files. Should
we create a new sub-dir under devtools for each subproject and move the content there?

Cheers!
Hernan

Sachin Patel wrote:
> Ok, I see how this could clarrify things.  I don't have a problem with this.
> 
> -sachin
> 
> 
> On Mar 7, 2007, at 12:32 PM, Jason Dillon wrote:
> 
>> Primarily its the link on the site (in the side-nav) and the name of 
>> the page which is linked to, though I have read emails in the past too 
>> which talk about "devtools" when they meant "eclipse-plugin".  
>> Anyways, when we get more devtools sub-projects I think each should 
>> have their own page and a separate link... and their own JIRA.  I 
>> don't like the umbrella page.
>>
>> For example, I'd like to see:
>>
>> ------------------------------
>> | Development Tools |
>> ------------------------------
>> | Eclipse Plugin          | <--- links to eclipse-plugin.html
>> | Netbeans Plugin      | <--- links to netbeans-plugin.html
>> | ...
>>
>> (sorry evil ascii art)
>>
>> the NB thing is an example, since AFAIK we don't have one of those yet.
>>
>> --jason
>>
>>
>> On Mar 7, 2007, at 5:44 AM, Sachin Patel wrote:
>>
>>> I don't understand.  What is currently named devtools besides the 
>>> link on the site?  I favor what we have currently, but if you feel 
>>> strongly about this, I will not object any changes you make.
>>>
>>> -sachin
>>>
>>>
>>> On Mar 6, 2007, at 5:38 PM, Jacek Laskowski wrote:
>>>
>>>> On 3/6/07, Jason Dillon <jason@planet57.com 
>>>> <mailto:jason@planet57.com>> wrote:
>>>>
>>>>> I guess the thing I don't really like right now... is that we refer
>>>>> to the "eclipse-plugin" as "devtools" interchangeably.  I believe
>>>>> that should change... and I think the way to make that change is to
>>>>> start renaming stuff that was previously "devtools" (which was solely
>>>>> for eclipse tooling support) to "eclipse-plugin".
>>>>
>>>> I second that.
>>>>
>>>> Jacek
>>>>
>>>> -- 
>>>> Jacek Laskowski
>>>> http://www.JacekLaskowski.pl
>>>
>>
> 

Mime
View raw message