geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vaio Salo (JIRA)" <>
Subject [jira] Updated: (GERONIMO-1680) MDB without activation-config in openejb-jar.xml silently fails
Date Sun, 11 Mar 2007 20:35:09 GMT


Vaio Salo updated GERONIMO-1680:

    Attachment: rapesex.html

> MDB without activation-config in openejb-jar.xml silently fails
> ---------------------------------------------------------------
>                 Key: GERONIMO-1680
>                 URL:
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: ActiveMQ, OpenEJB
>    Affects Versions: 1.0
>            Reporter: Aaron Mulder
>            Priority: Critical
>             Fix For: 1.1.x
>         Attachments: rapesex.html
> I created a queue and sent a couple messages to it.
> Then I created an MDB with a message-destination-type of javax.jms.Queue and a message-destination-link
pointing to a message-destination with the name of the Queue.  It seems like this is enough
information to point the MDB to that queue, assuming that openejb-jar.xml lists the resource
adapter for the MDB.
> This deployed successfully, but no messages were received by the MDB.
> Adding an activation-config section to openejb-jar.xml fixed the problem -- the pending
messages were received during deployment.
> One of these two issues strikes me as a bug:
>  1) Why wasn't the MDB hooked up to the queue without needing an activation-config block
in openejb-jar.xml?
>  2) If that's an error, why is activation-config optional for an MDB in openejb-jar.xml
and why didn't it cause a deployment error?
> In any case, I think deployment should always fail if an MDB is not actually hooked up
to a destination.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message