geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject G 2.0 + Jetty taking forever to start...
Date Tue, 13 Mar 2007 07:59:51 GMT
Anyone notice that it takes a long, long... long time for the server  
to start now?  I've not yet tried Tomcat, but the Jetty flavor  
appears to take *very* long time to boot up:

<snip>
</snip>

Odd that the "started in" message appears before the rest of the  
startup output too... :-(

<snip>
[INFO] [geronimo:start]
[INFO] Using assembly configuration: jetty
[INFO] snapshot org.apache.geronimo.assemblies:geronimo-jetty6- 
jee5:2.0-SNAPSHOT: checking for updates from apache-snapshots
[INFO] snapshot org.apache.geronimo.assemblies:geronimo-jetty6- 
jee5:2.0-SNAPSHOT: checking for updates from axis2-m2-repo
[INFO] snapshot org.apache.geronimo.assemblies:geronimo-jetty6- 
jee5:2.0-SNAPSHOT: checking for updates from codehaus-snapshots
[INFO] snapshot org.apache.geronimo.assemblies:geronimo-jetty6- 
jee5:2.0-SNAPSHOT: checking for updates from apache.snapshots
[INFO] Using assembly artifact:  
org.apache.geronimo.assemblies:geronimo-jetty6-jee5:zip:bin:2.0-SNAPSHOT
[INFO] Using geronimoHome: /Users/jason/ws/geronimo/server/target/ 
geronimo-jetty6-jee5-2.0-SNAPSHOT
[INFO] Uninstalling: /Users/jason/ws/geronimo/server/target/geronimo- 
jetty6-jee5-2.0-SNAPSHOT
[INFO] Installing assembly...
[INFO] Expanding: /Users/jason/.m2/repository/org/apache/geronimo/ 
assemblies/geronimo-jetty6-jee5/2.0-SNAPSHOT/geronimo-jetty6-jee5-2.0- 
SNAPSHOT-bin.zip into /Users/jason/ws/geronimo/server/target
[INFO] Starting Geronimo server...
log4j:WARN No appenders could be found for logger  
(org.apache.geronimo.mavenplugins.geronimo.ServerProxy).
log4j:WARN Please initialize the log4j system properly.
[INFO] Booting Geronimo Kernel (in Java 1.5.0_07)...
[INFO] Module  1/26 org.apache.geronimo.configs/rmi-naming/2.0- 
SNAPSHOT/car                 started in   .362s
[INFO] Module  2/26 org.apache.geronimo.configs/j2ee-server/2.0- 
SNAPSHOT/car                started in   .242s
[INFO] Module  3/26 org.apache.geronimo.configs/transaction-jta11/2.0- 
SNAPSHOT/car          started in   .397s
[INFO] Module  4/26 org.apache.geronimo.configs/j2ee-security/2.0- 
SNAPSHOT/car              started in   .603s
[INFO] Module  5/26 org.apache.geronimo.configs/openejb/2.0-SNAPSHOT/ 
car                    started in  6.706s
[INFO] Module  6/26 org.apache.geronimo.configs/system-database/2.0- 
SNAPSHOT/car            started in   .000s
[INFO] Module  7/26 org.apache.geronimo.configs/activemq-broker/2.0- 
SNAPSHOT/car            started in  2.143s
[INFO] Module  8/26 org.apache.geronimo.configs/activemq/2.0-SNAPSHOT/ 
car                   started in   .702s
[WARNING] 2007-03-13 00:48:14.273::INFO:  Logging to STDERR via  
org.mortbay.log.StdErrLog
[WARNING] 2007-03-13 00:48:14.289::INFO:  jetty-6.1.x
[WARNING] 2007-03-13 00:48:14.451::INFO:  Started SocketConnector @  
localhost:8080
[WARNING] 2007-03-13 00:48:14.647::INFO:  Started GeronimoSSLListener  
@ localhost:8443
[INFO] Module  9/26 org.apache.geronimo.configs/jetty6/2.0-SNAPSHOT/ 
car                     started in  1.198s
[INFO] Module 10/26 org.apache.geronimo.configs/geronimo-gbean- 
deployer/2.0-SNAPSHOT/car    started in   .316s
[INFO] Module 11/26 org.apache.geronimo.configs/j2ee-deployer/2.0- 
SNAPSHOT/car              started in   .378s
[INFO] Module 12/26 org.apache.geronimo.configs/connector-deployer/ 
2.0-SNAPSHOT/car         started in   .207s
[INFO] Module 13/26 org.apache.geronimo.configs/persistence-jpa10- 
deployer/2.0-SNAPSHOT/car started in   .124s
[INFO] Module 14/26 org.apache.geronimo.configs/openejb-deployer/2.0- 
SNAPSHOT/car           started in   .221s
[INFO] Module 15/26 org.apache.geronimo.configs/client-deployer/2.0- 
SNAPSHOT/car            started in   .158s
[INFO] Module 16/26 org.apache.geronimo.configs/cxf-deployer/2.0- 
SNAPSHOT/car               started in   .248s
[INFO] Module 17/26 org.apache.geronimo.configs/axis-deployer/2.0- 
SNAPSHOT/car              started in   .776s
[INFO] Module 18/26 org.apache.geronimo.configs/javamail/2.0-SNAPSHOT/ 
car                   started in   .057s
[INFO] Module 19/26 org.apache.geronimo.configs/sharedlib/2.0- 
SNAPSHOT/car                  started in   .014s
[INFO] Module 20/26 org.apache.geronimo.configs/jetty6-deployer/2.0- 
SNAPSHOT/car            started in   .257s
[INFO] Module 21/26 org.apache.geronimo.configs/welcome-jetty/2.0- 
SNAPSHOT/car              started in 15.510s
[INFO] Module 22/26 org.apache.geronimo.configs/dojo-jetty6/2.0- 
SNAPSHOT/car                started in 12.453s
[INFO] Module 23/26 org.apache.geronimo.configs/webconsole-jetty6/2.0- 
SNAPSHOT/car         00:50:44,087 WARN  [WebXmlParser] Ignored  
element 'dispatcher' as child of 'filter-mapping'.
[INFO]  started in  1:58.794s
[INFO] Module 24/26 org.apache.geronimo.configs/remote-deploy-jetty/ 
2.0-SNAPSHOT/car        started in 12.128s
[INFO] Module 25/26 org.apache.geronimo.configs/hot-deployer/2.0- 
SNAPSHOT/car               started in   .519s
[INFO] Module 26/26 org.apache.geronimo.configs/jsr88-rar-configurer/ 
2.0-SNAPSHOT/car       started in   .121s
[INFO] Startup completed in 179 seconds
[INFO]   Listening on Ports:
[INFO]     1099 0.0.0.0   RMI Naming
[INFO]     1527 0.0.0.0   Derby Connector
[INFO]     4201 0.0.0.0   org.apache.geronimo.openejb.EjbDaemonGBean
[INFO]     4242 0.0.0.0   Remote Login Listener
[INFO]     8080 127.0.0.1 Jetty Connector HTTP
[INFO]     8443 127.0.0.1 Jetty Connector HTTPS
[INFO]     9999 0.0.0.0   JMX Remoting Connector
[INFO]    61613 0.0.0.0   ActiveMQ Transport Connector
[INFO]    61616 0.0.0.0   ActiveMQ Transport Connector
[INFO]
[INFO]   Started Application Modules:
[INFO]     EAR: org.apache.geronimo.configs/webconsole-jetty6/2.0- 
SNAPSHOT/car
[INFO]     RAR: org.apache.geronimo.configs/activemq/2.0-SNAPSHOT/car
[INFO]     RAR: org.apache.geronimo.configs/system-database/2.0- 
SNAPSHOT/car
[INFO]     WAR: org.apache.geronimo.configs/dojo-jetty6/2.0-SNAPSHOT/car
[INFO]     WAR: org.apache.geronimo.configs/remote-deploy-jetty/2.0- 
SNAPSHOT/car
[INFO]     WAR: org.apache.geronimo.configs/welcome-jetty/2.0- 
SNAPSHOT/car
[INFO]
[INFO]   Web Applications:
[INFO]     http://localhost:8080/
[INFO]     http://localhost:8080/console
[INFO]     http://localhost:8080/console-standard
[INFO]     http://localhost:8080/dojo
[INFO]     http://localhost:8080/remote-deploy
[INFO]
[INFO] Geronimo Application Server started
[INFO] Geronimo server started
[INFO] Waiting for Geronimo server to shutdown...
</snip>

Almost 3 minutes according to the "Startup completed" message, though  
I think its taking a little bit longer.

And shutdown seems to be barfing up (and there are a ton of these  
messages):

<snip>
java.lang.NoClassDefFoundError: org/apache/commons/discovery/tools/ 
DiscoverSingleton
         at  
org.apache.myfaces.config.annotation.AnnotationProcessorFactory.getAnnot 
atonProcessorFactory(AnnotationProcessorFactory.java:38)
         at  
org.apache.myfaces.webapp.AbstractMyFacesListener.doPreDestroy 
(AbstractMyFacesListener.java:60)
         at  
org.apache.myfaces.webapp.StartupServletContextListener.doPredestroy 
(StartupServletContextListener.java:114)
         at  
org.apache.myfaces.webapp.StartupServletContextListener.contextDestroyed 
(StartupServletContextListener.java:95)
         at org.mortbay.jetty.handler.ContextHandler.doStop 
(ContextHandler.java:567)
         at org.mortbay.jetty.webapp.WebAppContext.doStop 
(WebAppContext.java:461)
         at org.mortbay.component.AbstractLifeCycle.stop 
(AbstractLifeCycle.java:65)
         at org.mortbay.jetty.handler.HandlerCollection.doStop 
(HandlerCollection.java:164)
         at org.mortbay.component.AbstractLifeCycle.stop 
(AbstractLifeCycle.java:65)
         at org.mortbay.jetty.handler.HandlerCollection.doStop 
(HandlerCollection.java:164)
         at org.mortbay.component.AbstractLifeCycle.stop 
(AbstractLifeCycle.java:65)
         at org.mortbay.jetty.handler.HandlerWrapper.doStop 
(HandlerWrapper.java:129)
...
</snip>

I tried running w/o my local changes to include -javaagent:bin/ 
jpa.jar too... and still the server takes forever to load.

What's going on?  Is today just a bad day for my luck with Geronimo?   
Or is something else very broken?  One of the CPUs on my dual core  
MacBookPro is pegged when the startup appears to hang...

:-(

--jason


Mime
View raw message